1

my Basic Plan, is to install the latest Version of LineageOS 14.01 via TWRP 2.8.0.1. This failed with an error "unknown command [log]". Next Idea: update TWRP to latest Version 3.1 and try again. So i tried to Flash the Recovery Partition via: "fastboot flash recovery twrp-version-titan.img" (during the Process i tried different Versions like 2.8.6 and 3.1) and fastboot responded:

    target reported max download size of 536870912 bytes
    sending 'recovery' (8724 KB)...
    OKAY [  0.296s]
    writing 'recovery'...
    OKAY [  0.204s]
    finished. total time: 0.500s

The messages on the Display seem to be ok (no error Messages) and I try to boot in Recovery Mode by choosing "Recovery" in Fastboot Mode. This works, except, that the installed Version stays the old TWRP 2.8.0.1 (I installed it some years ago). So i tried to boot TRWP directly via: "fastboot -c "lge.kcal=0|0|0|x" boot Downloads/twrp-3.1.0-0-titan.img", (worked) and install a new Version from SD Card. This failed, because TWRP couldn't mount anything.

During the whole Progress of try and error I messed something really up, because it won't even boot Android anymore. Flashing a stock Rom failed too.

Has anybody an idea, how to "force" an recovery update?

Sidenotes:

  • i'm working a mac
  • Android Studio is installed and updated incl. SDK Tools
  • i googled a lot
  • sorry for my english
  • I think your doing more than you need to... you should be able to flash recovery with sudo fastboot flash recovery twrp.img except replace twrp.img with the absolute path and actual filename. Have you tried just using the TWRP app and update twrp from there? – acejavelin Jun 23 '17 at 13:06
  • The Command: "fastboot flash recovery twrp.img" is exactly what I tried to do multiple times, except without "sudo". I tried it now with sudo, but it didn't make any difference. I wish I had known this app earlier, but now it's to late, since it's not possible to boot in Android anymore. Flashing a Recovery is so easy, that I can't figure the actual problem out. – CaptainRedbeard Jun 23 '17 at 14:35
  • So if you boot TWRP, it can't mount anything? Have you tried just reflashing the factory image with fastboot and starting clean... it sounds like the next step. This device is pushing 3 years old, the emmc could have failed too, we have seen more than one of these just die because the internal storage chip went out. – acejavelin Jun 23 '17 at 14:38
  • That's some good points: 1. When I try to wipe e.g. "Data", it sometimes work, and sometimes it fails with an Error "unable to mount". 2. in case, wiping "Data" worked (no errors) and I browse through the folder "data/app via filemanager, there is all App Data available, like he didn't do anything. 3. My Reason for an OS update/change was an increasing amount of "lags" during normal tasks. It wouldn't surprise me, if lags and this kind of flash problems have the same source: a dead memory chip. This would also explain, why make_ext4fs fails most of time. – CaptainRedbeard Jun 23 '17 at 14:56
  • Maybe it's time to accept my brand new expensive paperweight. – CaptainRedbeard Jun 23 '17 at 14:57
-1

Check the below link. This might help you.

https://forum.xda-developers.com/zuk-z1/development/win-zuk-z1-toolkit-0-1-alpha-t3235964

Though the solution mentioned is for Lenovo Zuk Z1 mobile phone. The process of doing it might help you solve your problem.

  • 1
    Do not do this... the process of doing with will either fail, or brick the device. This tool was written specifically for the Zuk Z1. Using it on another device will either have no effect or a negative effect. – acejavelin Jun 23 '17 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.