I'm using a Samsung Galaxy 10 tablet. How can I get Chrome to automatically translate a web page? My laptop will do so, either on its own or by right clicking. I have turned on Google translate, but it never offers to translate anything.

1 Answer 1


By default, Chrome offers to translate pages written in a language you don't understand.

If this functionality seems to be broken, then you can try some workarounds:

  1. Reset translation preferences

    • In Chrome settings, go to Site settings > Google Translate > tap Reset translate settings.

In most cases you should be now getting the popup that asks if you would like to translate the page.

  1. Using alternative browser with Language translate add on

enter image description here

How to use this add-on:

  1. Translate a word or sentence

    • Select a desired sentence on your current page and choose “More”
  2. Translate the whole page

    • Select “Dolphin Translate” and choose your target language

Hope this helps

You must log in to answer this question.