2

This is my first time here, so please be patient ;)

Recently I bought two smartphones, Blackview BV6000 for me and my lady. As I did some research I noticed that some Chinese brands have pre-installed spyware in Android build. Few days ago my girls' phone started to engage wifi, bluetooth, data transfer, precise location search and more on t's own. Quick scan with ADB through Command Line (CMD) on my Windows 10 x64 and I found these bastards:

1) com.adups.fota

2) com.adups.fota.sysoper

And I only scrached the surface. I wanted to root our phones so I could get rid of them, cause these apps are in .system directory and I have no access to them.

Here comes the hard part: First I tried Kingroot. It failed. Then dr.phone, it failed too. Then I tried this solution:

https://dreamworks75.blogspot.co.uk/2017/06/blackview-bv6000-smartphone-mt67xx-twrp.html

But no luck either. Every time I try to flash TWRP, so I can root from SuperSU it won't start after plugging the USB cable. So, in summary:

  • Yes, I did read a lot stack exchange posts, YT tutorials and internet guides before I wrote my down here :D

  • Android version 7.0 Nugat, Windows 10 64-bit (PC), USB cable provided with Blackview set, SP Flash Tool 5.1624 and 5.1720

  • I am sticking to the steps in guide from link

  • Phone is turned off

  • Phone is not plugged to PC before clicking "Download" icon in SP Flash Tool

  • I accessed developer options on phone with enabled USB debbuging and OEM unlocking

  • I'm using ROM, recovery image and scatter file provided from needrom.com (this one exactly: https://www.needrom.com/download/blackview-bv6000-4/) and I tried few more from various sources

  • I have drivers installed on PC (checked with USBDeview), MT67xx included

  • I tried SP Flash Tool both with and without "authentication file" field

  • After clicking "Download" button in SP Flash and plugging phone via USB nothing happens

If you have any advice, hint or other means to get rid of this unwanted apps I would be grateful. I spent already two days trying to figure it out.

0

I ended up reading this question after I also tried basically all of the steps / websites mentioned in the question. But I eventually managed to install TWRP.

  1. In order to make the SP_Flash_tool start flashing, after you plug in your phone that is turned off, press power button + volume up

  2. If the flash tool errors, you might not have the right scatter file or twrp recovery.img

  • If you are not sure about scatter file, try flashing a stock rom (I simply clicked on the latest) and follow the PDF mentioned in the link and you'll be able to use the scatterfile from the downloaded rom.

    After flashing the entire rom, it took quite a long time to boot (7 min ish) but the effect was as if nothing really changed. I had backed up my phone before flashing this stock ROM using the stock recovery so now is the time for factory reset, then restore data, then install all updates, re-enable again developer mode, usb debuging and oem unlocking and make sure that the updates actually got installed successfully and that there are no more updates.

  • Then try this TWRP (12.1 MB (12,783,616 bytes)) which also contains a scatterfile but that scatterfile didn't work for me, I had to use the one from the stock rom that I had just flashed. So in case the flashing still errors at this stage, I think you can tell that its because the version of TWRP is not right, not the scatter file.

Note: The file sizes are of the actual unzipped recovery.img

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.