1

I have followed every step of this instruction, but my Android phone can only access Google and YouTube – and no other websites. What is wrong?

It may be due to a DNS-server problem, but I cannot figure out how to fix this. When connecting to the hotspot, I cannot change any DNS-settings.

  • This is everything I have found: 1, 2. Changing the IP-preferences to “static” and typing in the addresses of Google-DNS-Servers does not help, because I cannot click on “save”. – Incognito Jul 4 '17 at 10:33
  • I have entered the configured (preferred) IP address and also used it for my gateway. But when I enter the gateway as DNS 1, my phone won’t let me save the settings. So, I have tried to use 8.8.8.8 as DNS 1 and 8.8.4.4 as DNS 2, but then, I will have no access to the Internet. – Incognito Jul 4 '17 at 10:47
0

Since the hosted Wi-Fi network is just like any normal Wi-Fi connection, you have to modify it, preferably using static IP address (this lets you change DNS settings as well)

  • Firstly check your IP, DNS settings on your windows machine by running ipconfig/all. Take note of the Microsoft Hosted Network Virtual Adapter.

  • Basically you need to check its configured (Preferred) IP address, you need this later to use as your gateway and(or) primary DNS server.

  • On your android device, long press on your newly created network and select modify.

  • On the IP settings, select Static and choose the IP address (check with your gateway for IP address range e.g gateway= 192.168.37.1, your desired IP will be anything from 192.168.37.1-255 etc)

  • Fill the first DNS (aka DNS 1) with the gateway IP address

  • Second entry choose any custom DNS e.g 8.8.8.8 or 8.8.4.4(Alternatively you can configure all Google DNS entries)

Edit

  • Your issue seems strange I reckon you need to reset IP settings and flush DNS:

  • open command prompt and enter the commands:

    netsh winsock reset all
    netsh int 6to4 reset all
    netsh int ipv4 reset all
    netsh int ipv6 reset all
    netsh int httpstunnel reset all
    netsh int isatap reset all
    netsh int portproxy reset all
    netsh int tcp reset all
    netsh int teredo reset all
    

This will clear the stored DNS cache in Windows. When the DNS becomes corrupt you will not be able to get to some sites. Flushing and rebuilding the DNS will fix that problem. Also resets Winsock entries & resets TCP/IP stack.

Update

  • The problem has since been resolved by using the settings below in the Internet Protocol property (of the configured adapter) in Windows:

enter image description here

Then on your android device set up static settings as describe above


This successfully resolved the matter:

You forgot to mention that The preferred and alternative DNS server should be 8.8.8.8 and 8.8.4.4 in Windows’ Internet Protocol Properties. You did not write anything into it, and I did not think about it either. But now it works perfectly!

| improve this answer | |
  • No, the problem is still prevalent. And even if I enter no domain and just an IP address, I still do not have access to the internet. I have presented the problem to a friend of mine who is interested in this kind of issue, too. If he will succeed and I can successfully copy his way of solving the problem, I will post it here. If I cannot solve it, something on my computer must function in a wrong way and both of you have given me perfect advice. – Incognito Jul 5 '17 at 14:32
  • Comments are not for extended discussion; this conversation has been moved to chat. – Dan Hulme Jul 5 '17 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.