I have Nexus 4 with broken touch screen and with Android 4.4.4 installed. I tried to connect a USB mouse using a OTG micro-usb adapter, but it doesn't work. The mouse doesn't even light up. Any idea why?

The adapter and the mouse are ok because I tried it on a different phone (Sony Xperia Z) and it works, mouse lights up, moves etc.


Nexus 4 doesn't support OTG as you can read here and see related questions on this site

It is possible if you overcome Kernel and power limitations as explained in Android Advanced: USB OTG on the Nexus 4

The first problem with getting OTG working on the Nexus 4 is that the kernel does not support it. This has been solved using a modified version of Franco's kernel. The second problem is that the Nexus 4 cannot physically supply the necessary 5 volts. The way around this is to use a Y-cable, and supply the needed voltage from an outside power source such as a wall outlet or external battery pack. Some users have also reported success using a powered USB hub.

  • 1
    well that sucks :(
    – katie
    Jul 4 '17 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.