-1

I am trying to install TWRP on mt LG Stylo 2 android 7.0 using adb. When i try to install it using this command

fastboot flash recovery twrp.img

I get the messages waiting for device. Thing is when i type

Adb device

My device shows. And i use adb to turn my SD card into internal storage. So why am i getting this error?

I enter recovery mode and hit enter fastboot but my phone just restart

  • 2
    Do you boot in fastboot mode? Seems not since adb devices still showing your device. Use adb reboot bootloader then perform the operation. – esQmo_ Jul 5 '17 at 10:33
  • 2
    @esQmo_ why not expanding that to an answer? From the question it's pretty clear you hit the nail on the head. – Izzy Jul 5 '17 at 12:09
  • Thats the thing. I get to recovery hit enter fastboot mode but my phone juat restart.. Forgot to add that will edit – DeusIIXII Jul 5 '17 at 20:55
4

You're probably not booting to bootloader mode (fastboot mode) that is why no fastboot command is recognized by the device. The prompt waiting for device means the computer is waiting for a device connected in bootloader mode.

Try to switch to fastboot with the following:

adb reboot bootloader 

Now check if fastboot sees your device:

fastboot devices

After that, perform all necessary action you want.

Note: You should have all drivers installed as well.

Update :

For LG, the command is a bit different. Start by allowing the bootloader to be written by enabling OEM unlock in the Developer options. Then:

adb reboot download 

Unlock the bootloader

fastboot oem unlock

(This will reset your device and you'll get a line of text saying the bootloader was unlocked whenever you boot the device)

Afterwards, flash the recovery with :

fastboot flash recovery xxxxxxxx.img

fastboot reboot

Alternatively you can press both volume down button and power button to get into fastboot mode.

  • Sorry i didn't reply. I made a noob error and deleted the adb drivers thinking there must be corrupted or something. Now can't seem to get them back even when i reinstall them – DeusIIXII Jul 7 '17 at 0:32
  • Search for LG United Mobile drivers or LG Mobile Drivers WHQL – esQmo_ Jul 7 '17 at 0:36
  • Hmm when i put the Fastboot oem unlock ut ran some command but my bootloader isn't unlocked ans next time i did it i got the Waiting for device again – DeusIIXII Jul 7 '17 at 22:41
  • How do you know it isn't unlocked? Waiting for a device is when there is no connection between the computer and the device. So if at first it worked ans afterwards it didn't, check hardware: usb cable, usb port, phone usb connector etc – esQmo_ Jul 8 '17 at 8:20
  • I did still not working.. And i didn't get the message it iant unlocked.. Been searching for day sont2 think i can root it – DeusIIXII Jul 8 '17 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.