1

When I enable Meeting (Vibrate only) audio profile Vibrate on touch is turned off and there is no way to change that through GUI.

Is there any other way? Maybe using root or smth else.

I use Android 5.1 on TCL P561U.

4
  • Prior versions of Android had no problems with haptic feedback when silent mode was active, perhaps automation may help. Jul 6 '17 at 12:46
  • What is the default state of haptic feedback? is global settings supposed to be on or only for meeting profile? Jul 6 '17 at 13:15
  • @xavier_fakerat I'm not sure what do you mean by default state. Haptic feedback by default is always enabled in Outdoor (Loudest ring and vibrate) profile and there is a slider in settings of General (ring and vibrate) profile. I want it to be also enabled in Meeting profile.
    – janot
    Jul 7 '17 at 19:05
  • I meant, is haptic feedback currently on despite whether device is in meeting mode or any other other ptofile (basically the global setting) e.g if its 'normal' or 'silent' does the seting remain on. I asked this because mine is globally off (whether I choose among different modes) I use android 4.3 so I can either have "on" or "off" as global setting, but after writing the coment I learnt this setting becomes off when silent (aka vibrate mode) is on in Android 5, so basically we had to override this with automation Jul 7 '17 at 19:09
1

One workaround is using . You can try using Tasker ($2.99 but available as a trial version for 7 days)

The goal is to use the profile context to check whether silent mode is on, if yes then haptic feedback is turned on (and becomes the global system setting)

Here is a workaround using Tasker:

Task

Go to the Task tab

  • Select "New Task + "
  • You can name this Task EnableHapticFeedback or anything.
  • Click "+" to add new Action
  • Audio >> Haptic Feedback [Set :On ; If %SILENT Is set ( this is intended to only reflect whether the device is in vibrate mode (vibrate) or not ) ]
  • Tap back to exit from this task
  • Press back all the way to exit (Your task is saved)

Profile (or Trigger)

Create a Profile which checks if silent mode (vibrate only ) is set

  • State >> Variable value >> %SILENT equals on

  • Tap back to exit from the profile, you should then link this profile to your task

    Note: You may add an exit task that keeps this setting on e.g if you want haptic feedback (aka vibrate on touch) to remain on but the above mentioned workaround works perfectly if you want it active in "Meeting mode"

Hope this helps

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.