When I watch youtube videos on my samsung epic 4g, most of the time when I click a video to watch it does the "Loading" spin gif animation forever, and I can see the little arrows on the 3g/4g symbol are off.

If I hit back and load again 3 - 5 times the arrows light up and the video acutally plays.

This is incredibly irritating.

Is there a way I can tell the phone to always keep the radio connection active while the charger is plugging in, or something like that?

Alternatively, does anyone know how if there is another way to fix this youtube issue?

Thanks so much, this is driving me crazy.

4 Answers 4


If you see the 3G/4G symbol and the arrows are just grey, that just means that you have data connectivity but there is no send or receive activity at the moment.

I guess you made an false assumption: The data radio is only off (deactivated) if you don't see the the symbol at all. Otherwise, if the symbol is there and the arrows are grey, your radio is on, but there is no traffic happening at the moment.

  • 1
    I see... so maybe this is an issue with the youtube application itself?
    – asawyer
    Commented Jan 6, 2012 at 13:23
  • @asawyer: Either that or there's a problem with the network. Try switching to a different cell tower by moving to a different part of the city or a different city and see if youtube plays acceptably there.
    – Kevin M
    Commented Jan 7, 2012 at 0:15
  • Check the comments on the latest update of youtube. That might give you a hint :)
    – Nanne
    Commented Jan 7, 2012 at 14:44
  • @Nanne How would one check that?
    – asawyer
    Commented Jan 9, 2012 at 13:42
  • (I don't know why I added this as a comment to this answer, and not on your question :) ) Anyway: market.android.com/details?id=com.google.android.youtube , and then press reviews, and sort by newest
    – Nanne
    Commented Jan 9, 2012 at 19:10

True network connectivity issues are usually pretty easy to identify as they would affect data to/from every app on the device. Are you also having trouble browsing the web, running speed tests, or streaming other types of video (like Netflix or other flash players)? Do you see the same issue on a stable WiFi connection?

If you're in an area where Sprint's Wimax coverage is spotty your phone might be switching back and forth between 2G/3G/4G trying to find the best connection - this could be the delay you're seeing. Even in areas with good 4G network coverage, some kinds of 4G radios can show inconsistent speed and reception results. If you disable Wimax/4G do videos load correctly? If you disable 3G as well?

This strikes me as a more app-specific problem. Does this occur with every YouTube video? Does changing the video quality ("HQ" button, top-right corner in landscape mode) change the symptoms? Check these areas, I suspect you'll find an operating mode that lets you view videos without frustrating delays.

  • It is consistent behavior with both 3g and 4g, but wifi works fine. How do I switch the phone into 2g mode? It occurs after every video, so the first one starting works fine, but the next one needs to switch back and forth from the play screen back to the prev. a few times before it will play. I always use the non-landscape one as well, so there is no hq button.
    – asawyer
    Commented Jan 7, 2012 at 3:06
  • @asawyer: Are you seeing the same behavior in other apps? Specifically Netflix, Videos, or the browser (playing a Flash video not on Youtube). It looks like I was mistaken, I'm not finding an easy way to make a CDMA device fallback to 2G; in either case, other apps' performance will help narrow the scope.
    – Mr. Buster
    Commented Jan 7, 2012 at 3:57
  • @MrBuster Youtube seems to be the only app with the issue. Netflix does weird things where it declares there is no network connection while everything else is fine, but i think that's just netflix being weird, and very rare.
    – asawyer
    Commented Jan 7, 2012 at 6:17
  • @asawyer: I've had issues with Netflix saying "no connection" too (dinc, miui 11.20), never troubles with YouTube though. Try the basics - clear the YouTube app cache, reinstall if necessary. Did get a chance to check if "HQ" mode hangs the same way?
    – Mr. Buster
    Commented Jan 8, 2012 at 2:23

Are you using a Battery saving app like Battery XL ?

If so, try to disable it, it caused me a lot of problems. Have you tried also to switch on Airplane mode and switch it back off and retry ?


Are you using the original YouTube app by Google? Alternatively, try using http://m.youtube.com using your stock browser.

  • I've tried this, but I get an error message all video's usually. Sometimes a reboot will let them work for a little while though, but I'd rather deal with the app nonsense then reboot the phone every couple hours.
    – asawyer
    Commented Jan 6, 2012 at 13:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .