0

I'm using a YubiKey Neo configured as an one-time-password generator. I'd like to use it with the YubiClip app but every time I pass it next to my phone, Firefox (my default browser) opens with a blank tab.

Any idea how to make Firefox stop reacting to NFC events? I don't need NFC for anything else than Yubikey so it's okay if some other functionality is broken by doing this.

  • Opening the default browser is the fallback action Android takes if an NFC tag contains a URL and no other app claims to be able to handle any data type on the tag. Could it be that the Yubikey is not configured correctly and only contains a URL? – Dan Hulme Apr 3 '18 at 9:43
  • That's not unlikely: I've not configured it at all, using it in OTP mode as it was when it shipped. On the other hand, the one time password appears in the Firefox address bar. – GDR Apr 5 '18 at 8:13
  • Sounds like the tag is incorrectly tagging the text as an URL then. It probably needs to be worked around in the app by editing the intent filter in the app's manifest to be broader, and recompiling it. You should suggest that to the developer. – Dan Hulme Apr 5 '18 at 13:58
  • Worth noting that there's an open bug report saying that the same thing happens in Chrome. – Dan Hulme Apr 5 '18 at 13:58
0

I solved this problem by opening the authenticator app before putting the key near my phone.

  • I tried that with YubiClip but Firefox still opened when it was active. – GDR Apr 1 '18 at 19:17
0

Figured it out. LineageOS 14.1.

Go to Settings -> Applications -> YubiClip. Click on "Open by default". Change "Open supported links" to "Ask every time".

Then place your yubikey next to the phone. Phone will ask you about the app to be used, choose YubiClip and click Always.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.