0

I have Asus Zenfone 5 (t00F) model. It was working fine and suddenly it's UI has stop working.

I tried restart couple of times but didn't work for me. I do already have the root and TWRP (2.8.7) installed into it,so I have done the factory reset from recovery mode.

And then after I am getting the error as:

can't mount /cache,
can't mount /system,
can't mount /data partition

I am trying to go to Stock ROM but in sideload mode also I am getting the same error.

I have also tried reformatting all three partitions but it is not working for any filesystem.(FAT,EXT2,EXT3,EXT4,F2FS) More digging into 'adb shell':

# cat /proc/partitions
major minor  #blocks  name
 179        0    7618560 mmcblk0
 179        1     131072 mmcblk0p1
 179        2       8192 mmcblk0p2
 179        3      32768 mmcblk0p3
 179        4       8192 mmcblk0p4
 179        5      32768 mmcblk0p5
 179        6     524288 mmcblk0p6
 179        7     196608 mmcblk0p7
 179        8      32768 mmcblk0p8
 179        9    1331200 mmcblk0p9
 259        0    5312492 mmcblk0p10
 179       40       4096 mmcblk0rpmb
 179       30       8192 mmcblk0gp0
 179       20       4096 mmcblk0boot1
 179       10       4096 mmcblk0boot0
 179       50   15662080 mmcblk1
 179       51   15655311 mmcblk1p1
# cat /proc/mounts
rootfs / rootfs ro,relatime 0 0cat /proc/mounts
rootfs / rootfs rw 0 0
tmpfs /dev tmpfs rw,seclabel,nosuid,relatime,mode=755 0 0
devpts /dev/pts devpts rw,seclabel,relatime,mode=600 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,seclabel,relatime 0 0
selinuxfs /sys/fs/selinux selinuxfs rw,relatime 0 0
tmpfs /tmp tmpfs rw,seclabel,relatime 0 0
pstore /sys/fs/pstore pstore rw,relatime 0 0
adb /dev/usb-ffs/adb functionfs rw,relatime 0 0
/dev/block/mmcblk1p1 /external_sd vfat rw,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0

# recovery.fstab
rootfs / rootfs ro,relatime 0 0 recovery.fstab
/sbin/sh: rootfs: not found

# cat /etc/recovery.fstab
cat /etc/recovery.fstab
/boot           emmc        /dev/block/by-name/boot
/recovery       emmc        /dev/block/by-name/recovery
/fastboot       emmc        /dev/block/by-name/fastboot
/cache          ext4            /dev/block/mmcblk0p6
/system         ext4            /dev/block/mmcblk0p9
/data           ext4            /dev/block/mmcblk0p10                   flags=encryptable=/dev/block/mmcblk0p3/userdata_footer
/factory        ext4            /dev/block/mmcblk0p3
/config         ext4            /dev/block/mmcblk0p5
/external_sd     vfat           /dev/block/mmcblk1p1                    flags=display="MicroSD";storage;wipeingui;removable
/usb_otg       vfat     /dev/block/sda1  /dev/block/sda       flags=display="USB-OTG";storage;wipeingui;removable

If somebody have any idea please help me.

Thanking you...

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • I have TWRP 2.8.7.0 installed and all this problem have started after formatting through TWRP.I have tried to remove this, but no luck. I have flashed stock recovery also then also TWRP is there and can't flash to anyother recovery including stock recovery. I have also tried via .zip file too but then also mobile is rebooting in TWRP 2.8.7.0 recovery only. At least I have ADB shell yet (Thank GOD), If anybody have solution to flash anyother recoery please comment it. – Khalid Waseem Jul 10 '17 at 9:38
  • If fastboot is working then try flashing stock rom and recovery. – Deepak Gangwar Jul 13 '17 at 15:58
  • @DeepakGangwar: I did try that but it is not working, TWRP recovery is stock into my phone, it is not getting new recovery even after flashing stock recovery. I did try to load stock ROM via sideload, but getting the same error there for mount points. – Khalid Waseem Jul 21 '17 at 11:51
  • Are you able to mount these partitions manually in recovery? – Deepak Gangwar Jul 21 '17 at 15:08
  • This typically means your partition table is corrupt or, more likely than not given that this device is 3+ years old, the internal storage chip that holds all your EMMC and partitions is failed. If you cannot restore to pure stock by flashing the factory image, this is likely that case (especially since you can't even replace TWRP). Most likely it is time to get a replacement device and retire this one to great recycle bin in the sky. – acejavelin Jul 21 '17 at 18:48
0

Had same issue with my 3.5 year old Zenfone 5. Tried almost everything to save it but nothing worked. It would not update the recovery even when fastboot flash was successful. Figured out it was failed EMMC and many other users faced the same issue in the same time period. Asus might had planted a uesd time trigged failure tech or something (Just guessing by the amount of similar failure in same time period of a month). Well i fixed mine by getting a ZF5(free :p) from a friend (his phone was not uses much as it had a broken screen maybe thats why it didn't failed) and then replaced my Motherbord with his.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.