3

I have a Samsung Galaxy Grand Prime, which isn't exactly the most high-end Android/Samsung Smartphone out there, I do not have a lot of features that other people have, and I was simply wondering if there is any way to change the system language to Japanese. When I go into Settings > Language and input > Language, I only have the options shown in this image: Language

Is there any way to change the language to Japanese or am I out of luck? Thank you in advance.

2

Background:

Firstly please take a look at the similar post: How do I add a new language?.

Adding a full language support for a device is done at ROM level, the langauges that the default keyboard will support are added before compiliation and the android keyboard will only give you the option to download dictionaries for the languages it supports..

Generally it is not easy to add a new language to the OS if it is not done by the manufacturer.

The best solution will be to flash a new ROM that holds your desired language, either a stock ROM made for your area by your device manufacturer or a custom ROM.


Having said that, nevertheless it could be that the ROM supports many languages but are hidden because of things like:

  • CSC (Customer Service Code) location
  • Region or
  • Carrier

This behaviour has been noted for Sony, HTC and Samsung devices. Luckily there is a possible workaround in this case (yay!).

Since you have a Samsung device, you may try Language Enabler (Wanam) which is recommended on this XDA thread.

Description

This application lets you activate your home language (locale) with ease.

Language Enabler activate all supported Samsung languages and keyboard inputs.

Starting with Android 4.2, the permission to change your system language became protected.

If you are familiar with Android developments tools, then you can grant the required permission to the App without root, by executing this command through usb adb -d shell pm grant com.wanam android.permission.CHANGE_CONFIGURATION

If you have root access on your device then Language Enabler can automatically do it for you.

This application supports all languages / locales: Arabic, Chinese, Indian, Spanish, French, Hebrew, Farsi... عربية، عبرية، فارسية.

There are some devices variants (US,Chinese) that remove completely all unused languages, sadly there is no much thing we can do in this case.

Features :

  • Choose language to be enabled (83+ languages)

  • Display Languages on their Locale encoding

  • Auto Backup your stock language settings
  • Restore your stock language settings

Important

This app doesn't add any language support, it just enable all supported languages, so if you don't get your local language after reboot, that means it's not supported in your ROM.

Please remember to share you feedback in comments section

  • Well I would like to say that, I finally got the command to run after a while because I had installed the incorrect program, but that is over. I ran the command and it showed no errors. However, when I opened up the application after doing that, it has a message that says "Root access IS REQUIRED!" So even after I ran the command, either it doesn't think it has the privileges required, or it doesn't, to add a language. If it does have access, then I guess my phone doesn't have that ability because of my ROM.. – user140052 Jul 9 '17 at 22:21
  • Please double check if your device is list in adb devices....Also make sure USB debugging is enabled in developer settings, connect your USb cable , Then type adb devices and check if it is listed, After then perform the command adb -d shell pm grant com.wanamandroid.permission.CHANGE_CONFIGURATION – xavier_fakerat Jul 10 '17 at 13:35
  • I rebooted my phone, rand the command adb devices which it then came up with a gibberish identifier for my phone, which I am used to, and next to it it said device. So I ran the command adb -d shell pm grant com.wanamandroid.permission.CHANGE_CONFIGURATION again, just to find out there were two options for the Japanese language, and one was decidedly not Japanese, or it would not set. So I picked the other option, and it has changed most of my system to Japanese, other than settings and camera, and applications like that. So I would like to thank you for your help! – user140052 Jul 10 '17 at 14:04
  • 1
    I tried this solution and works. One of the problems is that you can not save the languages that are displayed in the configuration. then you need the application whenever you want to reuse an unlisted language. – UselesssCat Jul 6 '18 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.