2

I built custom Cyanogenmod 13.0 for Galaxy S5 Exynos (G900H), however after I flash my ROM, the phone is stuck on bootloop with the Samsung logo turning off and on in a loop.

since CM and LineageOS does not support my specific S5 model (G900H) - I added the missing folders (device, kernel, hardware etc.) from fevax's repositories (https://github.com/Fevax).

After fixing some compile errors and adding all of the needed fevax's repositories, I successfully built a CM ROM zip file using the 'brunch k3gxx' command.

However, as I said, flashing it (after factorty reset) using TWRP recovery goes into bootloop. I also tried flashing only recovery/boot/system partitions using heimdall but it also leads to bootloop.

I thought that maybe the problem was the toolchain but after a long research I found out that it was probably ok (prebuilts/gcc/linux-x86/arm/arm-eabi-4.8/bin/arm-eabi-).

In addition, fevax has published his own ROM for this exact model and I flashed it successfully and it works fine. I tried to contact him (Email, xda messages etc.) but he didn't answer me yet. I want to make my own custom ROM, so his ROM only proves that it is possile to create a custom CM ROM for this special S5 model.

Currently I have no idea how to even understand what causes the bootloop, the 'brunch k3gxx' log does not show any unusual warnings or errors.

So, is there any way to debug a bootloop in Samsung Galaxy S5? Or any other way to get information about why that bootloop occures?

closed as off-topic by Dan Hulme Jul 10 '17 at 15:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about writing and publishing Android apps, writing custom ROMs, and other topics that are primarily of concern to developers are off-topic. Consider taking advantage of other resources that may be appropriate for your question." – Dan Hulme
If this question can be reworded to fit the rules in the help center, please edit the question.