2

I'm trying to get my Galaxy S8 to work with unity for gear VR development but I cannot seem to get ADB to find the phone.

I've enabled USB debugging in development options and also have the latest version of Android Studio and the SDK, I've also installed the Android 7.0 package in Android Studio and the windows USB drivers from that, I've also reset both the phone and computer after one suggestion, one person even suggested updating the USB drivers for the phone in device manager on windows to the drivers(Android_winusb) in the SDK folder but it says it cannot find any relevant drivers, also have tried adb kill-server and adb start-server.

Nothing I do seems to help at all. Also I really don't want to have to root the phone as that voids any warranty but from everything I've read there's no need to do that in order to get this working.

  • Samsung phones are often a bit funny with USB: you might need to install a Samsung-specific driver on your PC. – Dan Hulme Jul 10 '17 at 14:37
  • Thanks for the heads up, i didnt know that. Ive never heard of anyone mention a Samsung specific driver in all the videos and docs ive read so not to sure about that. – PyNuts Jul 10 '17 at 14:41
  • Maybe it is on charge only. Just press or long press on the device where it states connected and switch to data transfer. – Bo Lawson Jul 10 '17 at 15:17
  • Thanks for the advice but im already in data transfer mode – PyNuts Jul 10 '17 at 15:19
  • How about the path to the terminal? – Bo Lawson Jul 10 '17 at 15:23
2

I suggest you to connect your phone to your PC, and on your computar to go on Device Manager in control pannel and remove devices related to your smartphone.

Then, disconnect the smartphone from you PC.

Restart your PC and your phone.

Connect again your Phone to your PC.

Another try: Simply disable USB Debugging, while connected to PC. Re-enable It and connect to your PC.

  • My god thankyou so so much, the first option worked perfectly find albeit with having to reinstall the adb drivers from the android sdk but ive finally got it running so thankyou again – PyNuts Jul 10 '17 at 18:07
0

Google Driver works for Nexus and HTC etc.
For Samsung, I needed to find the correct SAMSUNG drivers and install them manually. As long as -The appropriate SAMSUNG driver has been manually installed -the device is in developer mode and -USB debugging is active on the device the PC should pick up the phone in ADB (when the PC has correctly recognised the phone, you should have a message on the Samsung device asking you to trust it). When device trusts the PC, and the correct drivers are installed, it should show up in adb devices

0

If you have a new macbook (2016 and newer) and are having this problem, make sure to try using all available USB-C ports. I believe only the thunderbolt capable ports will recognize the phone. Hope this helps!

-1

I had the same problem. What worked for me was to go to Developer Options and Rewoke USB debugging authorizations in my Galaxy S8+.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.