0

I just installed Textra to try out as a new primary SMS/MMS app. However, I've noticed that none of my previously-sent messages seem to have been imported into Textra. I see most (if not all) of my received messages, but none of my recently sent ones are there.

I recall having something similar happen when I downloaded Android Messages, to try out as an alternative to Samsung's built-in app.

Is there any way to get this all synced up, so I can have my complete history (at least, everything from since I started using this phone) in whichever SMS app I end up choosing?

Platform: Android 7.0 on Samsung Galaxy S8+

Software Versions:

Android Messages 2.2.076
Samsung Messages 4.2.00.143
Textra SMS 3.37

2
  • Textra settings > about > resync. Dues that help?
    – beeshyams
    Jul 10 '17 at 18:24
  • Already tried. Nope.
    – Iszi
    Jul 10 '17 at 18:26
0

Try this work around

  • Disable Textra as default SMS app

  • Take a backup of your stock SMS app messages using SMS backup and restore

  • Set Textra as default messaging app

  • Restore messages using SMS backup and restore backup, which you just created

  • All the messages (before you installed Textra ) should be available now on your Textra or alternative app

2
  • In the event you did send / receive SMS with Textra , take a backup to a different location (other than default of these messages using SMS restore and backup app ). For the process in answer use default backup location. At the end of all steps , restore from the other than default location
    – beeshyams
    Jul 11 '17 at 8:20
  • Has this worked for anyone? I just tried following the steps above, but my previously sent messages aren't showing up in Textra. I also noticed that when I did the restore, I had to first set SMS Backup and Restore as my default messaging app. Once the restore finished, I then set Textra to the default. Not sure if that has anything to do with anything, but that's the way SMS B&R worked.
    – David H.
    Jun 10 '18 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.