1

This is a continuation of this question, but here are the facts: I have a rooted Samsung Galaxy J1 Ace SM-J111F running the stock ROM in Android 5.1.1. I used this XDA-Developers guide to root it. It suddenly got bricked via FRP lock so I tried to unroot it using the stock boot binary.

Here is an Imgur album containing screenshots and images of the phone during the unrooting process.

Description of images:

  1. The phone is set on Download/Odin mode.
  2. Odin is ran as administrator and is loaded with boot-stock.tar provided by this XDA-Developers guide.
  3. The settings of Odin.
  4. This shows that the flash has failed.
  5. The custom binary is blocked by FRP and I have to restart the phone to flash again.

I tried downloading from www.samsung-firmware.com and www.sammobile.com but all downloads have failed. It stops midway and asks for a HTTPS certificate and the archive becomes corrupted between 20 to 70 percent.

I therefore decided to wipe the data using the stock Android system recovery. However, after rebooting it, the binary is still blocked via FRP lock. I've wiped the cache as well.

What caused this issue and how do I solve this?

  • What caused it? You likely modified something in system that tripped the modification check (it only occurs at boot), no way of knowing what for sure with the information you provided, the root method itself does not do this, but if you change the right thing it will cause this. The solution is to use ODIN or Heimdall to flash the factory image back to the device and return it to stock. – acejavelin Jul 11 '17 at 19:26
  • I'm pretty sure I haven't changed any critical system setting from the day the phone was rooted. I tried to flash it back to the stock binary using Odin, but FRP blocks it from happening which is why I was forced to factory reset the device as a last measure. – Pradana Aumars Jul 11 '17 at 19:30
  • You need to place it in Download mode first... otherwise can you update the question with a legible picture of the phone with the error message displayed. – acejavelin Jul 11 '17 at 19:31
  • I did set it in Download mode. Also, good idea, I'll add a photo of the phone with the error messages soon. – Pradana Aumars Jul 11 '17 at 19:33
  • FRP doesn't block flashing, may be you are trying to downgrade it. – esQmo_ Jul 11 '17 at 19:44
0

Be sure that the stock firmware is correct. It should be 1 or a few gigabyte(s) in size.

I've finally unrooted my phone. I used Updato's firmwares (which is the only one that has SM-J111F stock firmwares), specifically SM-J111F with product code XME and its PDA as J111FXXU0AQD2 (J111FXXU0AQD2_J111FOLB0APL2_J111FXXU0AQC2_HOME.tar.md5).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.