0

I have recently flashed Lineage OS 14.1 (fortuna3g unofficial build, Android Nougat 7.1.2) onto my Samsung Galaxy Grand Prime Duos (G530H/DS). Everything in working order, except the rear camera. Each time when I try to access camera from other apps(Whatsapp, Banking etc.) OR opening the stock camera app, it gives me "Can't connect to camera" message.

I have tried with 3rd party apps (open camera), some online tutorial fixes (cmfix camera fix for cyanogenmod), restarting camera app, restarting phone, reflashing LOS 14.1 etc.

I went back to stock to verify that camera works fine. There is no hardware issue.

Anybody had similar problem? Were you able to fix it?

  • 3
    This sounds like a bug that you should report to Lineage. There's likely nothing we can do to fix it for you. – eldarerathis Jul 14 '17 at 13:51
  • wasn't actually hoping anyone would do something to fix it for me... just really hoping someone had the same issue happening to them and would point to something I have not yet tried – Guga Figueiredo Jul 14 '17 at 16:18
1

Answering my own question.

My particular problem had to do with baseband and device codename, no bugs or problems with the build. For those, like me who were unaware of how this is related.

My baseband version matched the fortunave3g codename. So I should have installed that build of the of the ROM instead of fortuna3g, like I initially had. More information can be found in the device model master thread at xda-dev forums

I was unaware of the relation between the two things. But anticipating issues I had previously downloaded the three available builds (fortuna3g, fortunafz & fortunave3g). So all I needed to to was flash the appropriate build. Everything is working fine now.

Thanks to all for the attention. Ultimately my problem was lack of awareness.

0

This is a common bug in during early stages of android nougat development in custom ROM Lineage 14(cyanogenmod14), which was solved after few updates. This problem doesn't occur in latest builds.

Possible Solutions:

  1. Try to clear cache of stock camera.
  2. Try to find any Official Nightly Builds(which updates regularly, otherwise contact developer and report the bug).
  3. Try to clean flash(Backup user data, and wipe /system, /data, cache etc. install as new)
  4. Please check whether you can turn on flash light from notification shade.
  5. If you have used adoptable storage(SD card as internal), then check whether camera storage is internal or not.
  • already found problem.. turns out it has to do with baseband. I just had the wrong build. adding answer right now – Guga Figueiredo Jul 16 '17 at 13:50
0

As this is an unofficial build so most likely this will be a bug in the rom.

Update it to latest build if problem still persists then stick to the xda thread for the rom and wait for the developer to fix it or try fixing it yourself if you have experience in android builing.

Edit: By browsing through xda thread I found this comment. So it seems like there is no camera bug in new builds so you have to just update it to the latest build.

Try clean flash if the problem still persists.

  • Already have latest build, released on 11th. That comment you point out is in response to my very own post on their forums, in the same thread you linked above.. I am however, still with a camera problem.. Guess i'm out of luck... I was just hoping someone else had the same issue, and maybe a fix... thanks anyway. – Guga Figueiredo Jul 14 '17 at 16:16
  • Try clean flashing the latest build – Deepak Gangwar Jul 14 '17 at 18:05

protected by Community Jan 1 at 12:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.