At the place I work, everyone can log on to the wifi network with an iPhone. They just need to add a new network, type in the network name and choose wpa2 enterprise and then add their username and password (their own unique).

Everybody else with Android phones hasn't been able to connect, and it seems like they've tried for a long time.

I have to buy a new phone this weekend, and I don't really want to buy an iPhone. So I was hoping if somebody knew if the Samsung Galaxy Nexus (or any Android 4.0 device) has better wifi support than the older Android versions?

Sorry I don't know anything else technical about the wifi at work.

  • 1
    I can use WPA2 Enterprise on my 2.2 Vibrant. Jan 6 '12 at 17:03
  • WPA2 Enterprise networks frequently have a server-side certificate which authenticates the AP you are connecting to (ours do). It could be the case that some root certificates are missing on all Android devices and the identity of the server cannot be validated. Best consult your network administrator. Jan 27 '12 at 8:41

I've just checked on my Galaxy Nexus, and yes there's an option for WPA Enterpise (802.1x EAP) with EAP methods:

  • PEAP
  • TLS
  • TTLS

and Phase-2 authentication types:

  • None
  • PAP
  • MSCHAPv2
  • GTC

You can use an identity with a passphrase, or certificates

While I am running a custom ROM, I'm almost 100% positive this is in stock, as I could do the same on my Nexus One running 2.3


I had neither Android 4.0 nor uses WPA2 Enterprise, but according to this tutorial, it is possible to connect to WPA2 Enterprise, even though there is no indication about the support in the UI.

The underlying wifi stack have always supported WPA2 Enterprise, as it uses the wpa supplicant, only that there is not yet any support in the configuration GUI. I do not know if Android 4.0 have a new GUI that might support WPA2 Enterprise.


I have a Galaxy Nexus with Android 4 (ICS) and my company uses WPA2 Enterprise. Use Phase 2 authentication "MSCHAPv2" plus your user name and password. That worked perfectly for me.


In supporting the answer, I shall refer to the checking on the Wi-Fi Alliance site.

Look in:

  1. Filter by Company, select (Show All) from drop-down box.
  2. Filter Products by Primary Category, select Smartphone, multi-mode (Wi-Fi and other) from drop-down box.
  3. Filter Products by Secondary Category, select (Show All) from drop-down box.
  4. Put into the box, CID#, WFA11867

And click on Submit, the certificate for the Galaxy Nexus i9250 will be shown, after the search is completed, and can be found here

  • 1
    Where did you get WFA11867?
    – t0mm13b
    Jan 9 '13 at 16:37
  • If you already have CID, just put it on the CID input box and conduct a search.
    – Ivan Chau
    Jan 11 '13 at 4:58
  • If not, you first have to know the model code of the mobile phone (e.g. Galaxy Nexus model code: i9250), then conduct an advanced search to view the certificate on the result page.
    – Ivan Chau
    Jan 11 '13 at 5:00

Free app called "WiFi Connection" allowed connection to my corp's hidden network, 802.1x, PEAP, MSCHAPV2, no CA Cert. "LEAP WiFi Free" did not. Running Galaxy S3 (VZW), stock ICS. 4.04

  • Do link the apps.
    – Huey
    Oct 5 '15 at 11:48

Keep in mind that the options are available with the stock Samsung Galaxy Nexus, but unfortunately they don't always work, depending on the various security settings with the corporate network. In fact, my corporate wireless network worked just fine on Android 3.0 Honeycomb, but now that I've upgrade to 4.0 on my Xoom it's not working again. I also cannot connect my Samsung Galaxy Nexus to the wireless network, even though the same settings worked just fine on my Xoom running Honeycomb.


There is an application on the Android market/Play Store called "LEAP Wifi Free". Install it and you can now configure all your LEAP protected WiFi networks. Tested with Android 4 and Samsung Nexus :-)

  • 1
    Please also add a Play Store link to the app
    – Flow
    Oct 20 '12 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.