For some reason, I am suddenly getting a 5.2 error when I try to play videos. I found this on Reddit, but no one found a soltuion. Rooted devices can fix it, so here is my question:

Is there any way to solve the error on unrooted Samsung devices?

Checked the Netflix help center, but the 5.2 error isn't listed.

As usual, removing the app, clearing data, restarting device, tried over 4G, restarting netflix app, tried online and offline, previously viewed and unviewed, series and movies and every other suggested solution to different errors.

Nothing works. Any ideas if this is fixable, or if it is a Netflix issue?

Checking reviews on Google PLay reviews of the Netflix app and Reddit (see link above) there are a lot of people affected by this (5.2 error). It looks like it is Samsung only, as I can't reproduce it with my tablet (non-samsung)

4 Answers 4


Writing on behalf of OP since they cannot post due to inadequate reputation.

Even though reinstalling, rebooting, relogging, deleting data and trying different shows, I finally got it working by force stopping Netflix. No clue why, no clue if this is a permanent fix, but I can at least watch shows and movies again. Doesn't look like there has been an update to address this.

Force stopping the app at least worked, even if it isn't a permanent fix. It may not last long, but it at least works now.


I recommend you contact netflix directly. There is an old APK that they will provide to circumvent this problem. its a temporary fix but it works


User hawky11 and nickfury27 on Reddit reported that installing an older version works. The version is quite old (v3.1.xx) and may be having security vulnerabilities, so be on your guard when using it. Nonetheless, here is the link to official source: https://help.netflix.com/en/node/24776

Some other users tried v4.13.xx or v4.16.xx but that didn't benefit them much.

  • I don't have a Samsung device at my disposal, so I cannot vouch for the effectiveness of this answer.
    – Firelord
    Commented Jul 21, 2017 at 6:52

We need to wait, this happens since samsung S6 last update, netflix must update there app. until than, wait, wait and wait

  • This issue has been known for a few weeks, they are aware of the issue. Yet there is nothing about the error in the help center
    – user174673
    Commented Jul 18, 2017 at 8:00

You must log in to answer this question.