1

I have a strange problem on one of my old phones. I have an old Android device running Android 2.3.4, and it works perfectly. But, I found that, it can't access to https sites with the basic browser installed on the phone when it is connected to my Wi-Fi network.

But, if I visit the same site, for example " https://www.google.com " , with an another browser, for example Opera mini, that have a VPN integrated, it works perfectly.

The strange thing is if I use another connection, for example another Wi-Fi network, it works, also with the basic browser. This problem doesn't happen with other devices, the modem/router works perfectly with all the type of devices that I have on my house. I already perform a factory reset on my device and also a factory reset of modem, but the problem is still here. How can I solve this problem?


@Izzy When I try to reach " https://www.google.it " logcat shows these warnings:

W/System.err: java.io.IOException: www.google.it/2a00:1450:4009:811::2003:443 - Network is unreachable
W/System.err: at android.net.http.HttpsConnection.openConnection(HttpsConnection.java:335)
W/System.err: at android.net.http.Connection.openHttpConnection(Connection.java:389)
W/System.err: at android.net.http.Connection.processRequests(Connection.java:250)
W/System.err: at android.net.http.ConnectionThread.run(ConnectionThread.java:144)
  • 1
    Not a solution (hence a comment instead of an answer), but to know what's going on you could investigate the logs. If the browser has trouble, it should put something there. Watch out for the "E:" (error) and "W:" (warning) lines, they are the most likely to give you a clue. – Izzy Jul 17 '17 at 14:58
  • Thanks,..the router doesn't have any proxy at all,..Opera mini uses his VPN to tunnel traffic, with VPN enabled the https sites work but if i disable the VPN, the https sites doesn't show in Opera mini,.....I think it's a problem extended to multiple browsers.....I'm looking at the logs. – user228883 Jul 17 '17 at 15:35
  • Some problems with https may occur because system date is incorrect. Other problem is old android may not have complete list of trusted certificates, VPN works because they handle this. – Kenumir Jul 19 '17 at 6:06
  • @Kenumir Thanks, the date on my phone and the date in the router's settings is ok, ...for the certificates, is it possible that these certificates are out of date?,...because I don't think that I haven't the certificate of the https site of google.com, ...How can I verify that it is actually a certificate issue? – user228883 Jul 20 '17 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy