1

My Alcatel Idol 2 running Android 4.2.2 , won't connect to my laptop but it charges. I tried

  • Installing "right" drivers on my laptop

  • I tried 4 different USB cables and it still doesn't work

  • I tried also to connect other phones via those cable and they charge but my Idol 2 won't connect to transfer some files

  • I also tried to connect to another 3 laptops (with different windows (7,10) and it won't connect either

  • I tried to turn on and off USB debugging. Also looked up for some USB settings and found nothing in mobile closed)

  • Safe mode and factory reset didn't help either

I need to flash a new ROM because my mac adress and bluetooth adress got somehow deleted, so I can't download nor send any softwares in it (i don't have enough internet data to download the ROM to my Idol 2, and I can't connect to any hotspot)

Any ideas how to fix it?

  • Please make your posts readable by proper formatting and correct grammar. I attempted to improve. You can edit to revise – beeshyams Jul 18 '17 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.