1

Background: Device is Toshiba WT8-A Partition is FAT32 EFI grub and Android x86, all Windows partitions have been deleted.

I have tried various installs from Marshmallow, Bliss and Nougat. All with varying successes. I can link to the files that I installed if requested.

Marshmallow had many failures (ie GPS, WiFi, rotation etc) but would boot. Bliss had the same failures but would boot. Nougat Android x86 had none of those failures but would not boot.

I can consider going back to Lollipop if need be. But firstly let me explain what is happening:

I can install fully, including the grub and I can load Nougat and everything runs smoothly. If I then reboot, an endless loop occurs and Android does not load.

I have looked at the command line and there is nothing to change. I tried a different EFI from a previous install and changed the targets, but I guess there is far more to change than just that, it did not work.

I reinstalled fully Nougat and instead of starting Android x86 I rebooted (as one of the options) and Android rebooted. I updated the apps Google wanted to update, rebooted and then the endless loop occurred again.

I can get to the point where it has detected Android and is trying to boot, but instead of booting, the tablet appears to switch off and start again.

Does anyone have any solutions? Troubleshooting guide or help?

TIA

  • I encountered the same problem. For me it is because Android x86 breaks the ext4 file system it lives in. After booting an Live CD and running e2fsck, Android x86 booted successfully again. – DDoSolitary Sep 11 '17 at 9:46
0

Emerge some workaround here,

-same as your case -dual boot is the main diference (mint 18.2)

When i boot the second time, infinite loop.

Workaround : -boot on some live linux, delete dalvik and data caches. -make a script that sleep more than android mean boot time before it run rm commands to erase caches.

Not as beautiful as it would be .. .. .. but work )

I'm searching for the root cause

Not the answer you're looking for? Browse other questions tagged or ask your own question.