I am using android version 6.0.1 kernel 3.4.0-gad29d11. I have tried a laptop with windows 8.1 and desktop with ubuntu 16.04. I have tried installing ADB software and google drivers, using different usb cables, putting the device into developer mode with usb debugging on and MTP active, a galaxy 3 phone also is not recognized on either computer. Linux does not show a new usb connection when N7 attached and windows does not show any unknown/android device in device manager. All other usb functions (e.g., OTG operations, charging, etc.) work with the N7.

What can I do?

  • An update: using a suggestion from a similar post [1] I tried removing all usb extenders, hub, and connecting to a different usb port. I rebooted the N7 and still no connection. I tried using a different usb cable and I observed a “developer mode enabled” notification flicker briefly. I then wiggled the connector and android device showed in my device manager! [1] Google Nexus 7 not recognized via USB – compneurophile Jul 26 '17 at 0:35
  • I am curious could it possibly charge yet not do MTP if the cable is connected in the wrong position? I will test further with cables, cable positions, cable extenders, etc. and edit updates here with what I find. – compneurophile Jul 26 '17 at 0:35
  • Concerning Ubuntu, you may be interested in this answer, which worked for me on Debian. It basically describes a way to mount Android's MTP and let it be seen on Thunar. See if it helps. – Death Mask Salesman Jul 26 '17 at 11:23
  • @DeathMaskSalesman thanks for the advice, I have found some of the issue is with the port only connecting at certain plug angles and I will test first in Win but then move into Linux, your method will be useful at that time. – compneurophile Jul 27 '17 at 23:40

I have had this problem on a labtop of my mom's. Maybe there is some security feature on the mainboard, I could not try it on this labtop because it is not mine, but that might be the issue. Look out for secure boot for example. (it would be interesting to know if it is a Dell, if yes this could be an issue referring to the company or kind of bios/uefi) I have tried it on another pc, desktop this time and I did not have any trouble. So if there is no option to fix it in the bios, just use another pc, (preferably a desktop) and flash on this system if you can.

  • Thanks, I was able to get it to work once I held the wire in a certain position in the plug. It still seems to charge when in a different position but I am going to test it further to understand why a certain connector position allows MTP. I may try removing secure boot but I have seen a similar issue on ubuntu that does not use secure boot – compneurophile Jul 26 '17 at 12:13

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.