0

I have tried everything that I can think of here, but somehow my Win10 PC won't finish the driver installation.

I tried fastboot mode, recovery mode, MTP connection, USB debugging mode. Win10 fails to recognize the drivers at all. I also tried the universal drivers, they failed too. Just "Install failed" message when I use universal drivers.

I also tried removing all USB device drivers, but that didn't work either. So, right now, my phone is stuck in a weird position. I can't fix my IMEI issue because I can't connect to PC. And I can't connect to PC because it does not get installed properly. Device is getting detected but the device manager just shows error saying "A file could not be found", or "An installer cannot perform installation". No proper error code available here, but I can definitely provide exact error messages, if that helps.

Error Message in Fastboot/Recovery Mode: Device USB\VID_0BB4&PID_0C01\8PR8EMEEWCOFQ8AI requires further installation.

Edit: Tried removing every usb driver, then reinstall, then use Lenovo usb drivers. Same problem. The drivers do not get installed.

  • Disconnect device from PC, Remove all drivers from the PC, reboot , plug in the device and install recommended /device specific drivers – beeshyams Jul 27 '17 at 16:50
  • Okay, let me try rebooting after deleting the driver. Will get back to you in a bit. BTW, Windows automatically installs some random driver as soon as I connect. – jitendragarg Jul 27 '17 at 16:52
  • Yes, that's the lousy part of windows - suggest you first install whatever are the recommended drivers for your device as suggested in your device forums . If that doesn't help, install what windows Recommendations. If this also didn't help, please update your question and let others help – beeshyams Jul 27 '17 at 16:56
  • Another option could be to install Linux in dual boot mode - you don't need to bother about drivers. Android is automatically recognised – beeshyams Jul 27 '17 at 17:12
  • Done. Tried your suggestion. Nothing. Stupid windows won't let me install drivers. BTW, I am trying to update imei, because my imei is null after the update. It was still working fine till I rebooted. Now, I can't connect to network, or connect phone to pc to just start from scratch. Funny thing is, phone is still rooted. So, I tried using "chamelophon" app. But nothing. It didn't work at all. It showed message saying, "please shutdown phone now". and when i started it again, no sim detected. even the sim settings got disabled. – jitendragarg Jul 27 '17 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.