4

For example, this very site, when I click on a notification, it opens the page in the Android Instant App.

I normally browse Stack Exchange sites on mobile web (mobile web version is great!).

Ever since it prompted me to try the instant app, I haven't been able to make it stop using the instant app.

The only workaround is to long-press a link then open in new tab. Then I can navigate to the new tab to see the web version.

2

The sure way is to disable the whole instant apps feature.

From Google Play Help,

Change how you open instant apps from links

You can change your settings to open links into instant apps or websites. If you turn on “Upgrade web links,” and click certain links, the instant app may open and you’ll be able to use some of it’s features, without actually installing the full app. If the setting is turned off, the link will open in a website. Learn more about instant apps.

  1. On your Android phone or tablet, open the Google Play Store app .
  2. Tap Menu and then Settings.
  3. Select Google Play Instant.
  4. Turn on or off Upgrade web links.

Even when this setting is turned off, you can always continue to try instant apps by clicking on links that are Google Play branded.

  • Previously, disabling/enabling it per-app doesn't seem to possible as have been proven with Stack Exchange Android app. Now that I've Instant Apps on this device, looks like there's "Manage links" in the settings from above. However, I still couldn't find any example links to try if it's possible disable/enable per-app. – Andrew T. Oct 2 at 15:10
  • revised this answer to reflect google answer but indent formatting for first "1" needs fixing. I was editing this about the same time. – Scott R Oct 2 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.