0

After all for a game, I've done all the stuff that gets it to play the way i love.

I did the following in the order as it is.

  • Backed up my contents
  • Unlocked the bootloader
  • Flashed TWRP recovery
  • Installed elementalX-G4-1.04
  • Flashed SuperSU-2.82
  • Wiped cache partition

Now my phone was rooted and I restored all the contents and data. All of a sudden Pokemon GO is not working and I got to know that it won't work in rooted devices since it's failing Safety Net tests. After going through some threads, I get to see that installing suhide might bring back life into the game.

I downloaded suhide0.54 and booted into recovery mode, flashed suhide0.54 and tried rebooting. Phone got stuck at Moto logo for a long time. I tried wiping cache and rebooted but still the same.

Tried flashing suhide-0.55, wiped cache partition and rebooted system. Still the same condition. Please help me out on how to get out of this situation.

Model : Moto G4 Plus

Version : Android 7.1.1

1

You need to uninstall suhide. There is an uninstaller.

Check this post:

https://forum.xda-developers.com/apps/supersu/suhide-t3450396

And scroll to the downloads section. Download the file with 'rm' in the name. Transfer it to your phone and flash it in TWRP. Make sure you have the latest version of TWRP. Reboot.

I would suggest buying a cheap phone and experimenting with that. Unroot the G4 plus and do all the stuff with it that you can do unrooted.

In terms of the phone to buy to root etc, I would suggest either a used phone (make sure you can unlock the bootloader before buying) or a new moto e, maybe. If you are in the UK, I would suggest buying a used phone. You can unlock the bootloader on an HTC One M8, which you can pick up for about £90.

https://htc-one.gadgethacks.com/how-to/unlock-bootloader-root-your-htc-one-m8-0154444/

In the US, the new Moto E is $99 on Amazon Prime or $129 normally on Amazon.

Hope this helps!

  • Thanks for the link though. I flashed suhide-rm file and my phone booted perfectly. I am not experimenting with root. All i did was to play pokemon go as the march security update messed up with the gameplay i used to . – WarriorPrince Jul 31 '17 at 7:19
  • Oh, ok. I thought you rooted it in the 1st place for experimenting. As long as the Suhide rm file worked, that's good. – Ben Aviani-Bartram Aug 7 '17 at 9:01
-1

You got bootloop for SuperSu may be.

Remove SuperSu. You will find super su uninstaller on internet. Flash Magisk. You can hide supersu in magisk menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.