0

I got this new phone (An LG K 20 Plus from MetroPCS, model# LGMP260, running 7.0) roughly a month ago. Roughly a week afterward, apps started crashing out of nowhere. Sometimes, it was triggered by actions. If I clicked the wrong thing, whatever app I was in might crash. If I scrolled too fast, the app might crash. If I tried to load something big, the app might crash. This mostly happened with Relay for Reddit, but mostly because I really only used that app. But more often than not, it would just be in the background at random. I would often get "Photos has crashed" messages, despite not even having opened Photos. It wasn't even the app I was running sometimes. During these weeks, some of the highlights of apps crashing have been:

  • Nova Launcher
  • Home
  • Call Management
  • System UI
  • Settings
  • LG Keyboard
  • Google Play Store
  • Google Play Services

Reboots don't even help much. Sometimes, it will just freeze on the MetroPCS screen during boot. Others, it will boot, but then show just a black screen until I hold down the power buton to turn it off. Others, it will boot, but then say "System UI has stopped," and I have to take out the battery to reboot it. And sometimes, it will just boot normally, sending me back into the normal crashes. Oh, and I can't even google anything because Chrome always throws an "Aw, Snap!" message whenever I go to any page whatsoever.

And now recently, Google Play Services have been giving me some trouble. It would often start randomly saying "Google Play Services has stopped" every few seconds until I reboot. And then, two days ago, the Play Store would start crashing when I went into it. Upon inspection, I found out that Play Services had decided to just uninstall itself. I found a mirror and reinstalled it from an APK, but it would either say that Play Store wasn't installed, or was updating. And then yesterday it went back to normal like nothing happened.

I even tried resetting the phone. Twice. It didn't work. In fact, it took me a while to set it back up because it would give me the "Google Play Services has stopped" message during the set-up sequence. And then, after a dozen reboots or so, it decided to grant me permission to re-enter.

There's no way this is a software problem, or a reset would have fixed it, right? Is this a hardware problem? Do I need a replacement phone? I apoloize for the wall of text, but there's a lot going on that I need to address. Thank you for your advice.

0

I am having the same issue. Try booting into safe mode. That's what I did. This should give you some info on if this is a software problem or a hardware problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.