2

in the past WhatsApp videos opened by default in the video player you annoted on Android as the default video player. in my case all videos in my Android phone (an Xperia z ) will open with MX player which is the default player I made for all video and audio files. however newer versions of WhatsApp will force all videos to open in an internal WhatsApp player which is a very rudimentary player. it will not automatically Orient the video besides volume boosting. other than actually use an explorer and navigate to the WhatsApp video folder , is there a way to force all WhatsApp videos not to use the hapless internal WhatsApp player but use MX Player. I don't think an older version of WhatsApp that permitted will run without problems right now.,.. I very consciously avoided WhatsApp upgrades to a point where my WhatsApp itself crashed repeatedly and would not work & that is when I upgraded

  • Use this app as default handler to select the player of your choice – beeshyams Aug 2 '17 at 3:28
  • I already configured my default video player as MX Player and it will play all videos when opened through Android Explorer with MX Player. problem is we are opening WhatsApp video through WhatsApp the app and the app is forcing all videos to open with an internal video player so this app that you pointed out loud no use it has not succeeded in changing his behaviour. – user1874594 Aug 2 '17 at 3:35
  • I understood the problem and suggested this as it worked in similar situations. Maybe WhatsApp hndled differently. Suggest back up you WhatsApp, uninstall and reinstall and this app should give you choices – beeshyams Aug 2 '17 at 3:42
  • Or try the app mentioned here android.stackexchange.com/q/136679/131553 – beeshyams Aug 2 '17 at 4:03
  • sure will do that every time I had to uninstall and reinstall I've lost some history so I gotta make sure backup is latest on up to date so it takes some time but I am a little Pessimistic because the internal WhatsApp player handles all videos and images by self and does not give the other interface a chance. I would try reboot before I uninstall and reinstall thank you for the suggestion – user1874594 Aug 2 '17 at 13:04

protected by Community Oct 25 '17 at 16:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.