1

My phone is Sony Z5 Compact Nougat.

What I had done is as below:

  1. Unlock Bootloader
  2. Use the following command to flash twrp recovery fastboot boot recovery.img fastboot flash recovery recovery.img fastboot flash boot boot.img The file are from this link : https://forum.xda-developers.com/z5-compact/orig-development/twrp-z5-compact-t3235161

    Version of twrp : 2.8.7.0

  3. Wipe > swipe and factory reset.

    So now when I try to reboot, it says No OS Installed! Are you sure you wish to reboot?

  4. I tried to flash both Paranoid Android (Official) and Carbon Rom (Unofficial) both in the format of .zip and it show me below error message: mount: failed to mount /dev/block/bootdevice/by-name/system at /system: No such file or directory unmount of system /system failed: no such volume Tried few times but same problem

  5. I then also tried Advance > ADB Sideload, my command are as below adb sideload carbon.zip adb sideload paranoid.zip The error message is also the same as above

As far as I concern I cannot find twrp version that are above 3.0 for this device, and now I cannot boot into any os as there are no os that I can boot into, hence cannot perform the step for recovering stock rom .ftf using flashtool, what should I do in order to get back to at least stock Rom or any way to fix the failed to mount problem, which I suspect it is because of the old version of TWRP.

Additional : I am very sure that my firmware version is the latest version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.