-1

On any other device, I was able to go to Settings, scroll to Developers Options and toggle it On/Off. On Nexus 6P, this toggle does nothing. If I turn it off, next time I look at it, it shows as on even though I turned it off minute ago.

I am building Android app so I do need Developer Options. I dont want to disable or hide it, I just want to be able to use the toggle to turn it on or off as I need. Just as I did with many other android devices.

Anyone else noticed this?

enter image description here

I tried suggestions from this link http://visihow.com/Disable_the_Developer_Options_on_Nexus_6P but that did not resolve anything.

I would also like to note that until very recently, perhaps 3 months ago, I was able to disable Developer Options by simply going to Settings->Developer Options -> Turn toggle Off

migrated from superuser.com Aug 3 '17 at 16:28

This question came from our site for computer enthusiasts and power users.

  • Seen this ? – beeshyams Aug 3 '17 at 16:32
  • @beeshyams Yes, I saw it and did exactly as described. This disabled developer options completely which is not what I wanted but anyways, upon enabling Dev Options again, the toggle was always on On. Turning it Off, closing the settings, then reopening it again, shows it as On even though I set it to Off – dbnex14 Aug 4 '17 at 18:23
  • In which case, edit your question to make it clear that you have tried the suggested steps but it didn't work. IMO, it looks like a specific issue with your device, since Google recommended method is linked by me below Antz's answer – beeshyams Aug 4 '17 at 18:34
  • Sorry, but question is very clear, but you are right, adding a line saying that I already tried suggestion from the link you posted helps, I'll do that. – dbnex14 Aug 4 '17 at 18:39
2

Go to settings, click Apps, then scroll down and select settings, click storage, you should have a pop-up window, click on clear data, then you finally click ok. It should bring you back to your home screen and Developer Options should go off until you decide to turn it on again.

  • Sorry but none of the answers so far make any sense. I updated my question as well – dbnex14 Aug 3 '17 at 16:26
  • This has been quoted as the way to do it in the Google forums help which had a linked video and a similar blog has been quoted by me below your question. I don't have the device to verify +1 – beeshyams Aug 3 '17 at 16:37
  • @Antz This disabled developer options completely which is not what I wanted but anyways, upon enabling Dev Options again, the toggle was always on On. Turning it Off, closing the settings, then reopening it again, shows it as On even though I set it to Off – dbnex14 Aug 4 '17 at 18:23
1

I suspect this strange behaviour is caused by some setting that requires developer options to be enabled, but itself is not deactivated for instance USB debugging., transitions/animations etc.. (this has been observed to enable developer options in some LG builds typically when the battery saving feature disables animations at 15% )

As a workaround try this:

  • Go to developer options, turn off debugging,

  • Then disable the developer options with the switch on top of the screen (same as your screenshot)

The trick is to first deactivate setting that uses developer options then toggle it off

  • sorry but your steps are making no sense, can you please try them and update. Tx – dbnex14 Aug 4 '17 at 18:14
  • Sorry let me fix – xavier_fakerat Aug 4 '17 at 18:15
  • 1
    Nope, not working. As described already, and regardless whether I follow your 2 steps or not, behavior stays the same. Toggling Developer Options to Off (in top right corner like on my image) shows it as Off. But if I close Setting, then reopen it and go to Developer Options again, it will show it as On, even though I turned it Off just a minute ago – dbnex14 Aug 4 '17 at 18:25
  • Your question is a bit ambiguous, its not clear what you're trying to do. You say " I don't want to disable or hide it, I just want to be able to use the toggle to turn it on or off as I need" isn't toggling off disabling it? Also my point is some setting is causing the Developer options to be turned on, such that even if you disable it, you'll later find out it automatically turns itself on......as has been reported due to battery saving feature which turns off animations at a certain battery percentage in some LG builds, so either disabled it completely as suggested by @Antz or leave it – xavier_fakerat Aug 4 '17 at 18:29
  • 1
    Ok I understand, maybe its a bug of some sort? If I find something I will update accordingly ;) – xavier_fakerat Aug 4 '17 at 18:45
1

Factory reset resolved this issue

  • To whoever downvoted this, have any idea why you downvote the only working solution for me? After trying numerous things including Google suggestions, they recommended this last resort thing. Yes it is a sad solution, and to add, Nexus 6p is the worse phone I ever had – dbnex14 Aug 5 '17 at 16:11
0

OK. FIRST MAKE SURE THAT NO ONE APPLICATION IS USING THE DEVELOPER OPTIONS. LIKE IN MY CASE FAKE GPS IS USING DEVELOPER OPTIONS SO I JUST HAD TO DISABLE IT TO TURN OFF THE DEVELOPER OPTIONS. THE TRICK IS DISABLE THE APP OR SETTINGS THAT IS USING THE DEVELOPER OPTIONS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.