1

I am using a mobile which is having Android Marshmallow. Whenever someone is sending a Whatsapp message to me when the phone is locked. The message is showing up in lock-screen as plain text.

So anyone can just pick up my phone and press the unlock button and they can see what someone texted me without unlocking the phone.

How to stop this from happening?

3
  • 1
    Settings > sound and notification > when device is locked > don't show notifications at all. This will prevent any notification on lock screen, if you are using a device that didn't have a modded UI like Huawei etc. For WhatsApp : settings > notifications > pop-up notifying > choose no notifications or only when screen on
    – beeshyams
    Aug 3, 2017 at 19:43
  • @RahulGopi nope this is not what I am looking for. I am looking for the lock screen. Aug 4, 2017 at 7:04
  • Select Hide all sensitive data on lock screen from App info/Notifications for WhatsApp. BTW this is for Android 7 and I have no idea if that's available for Marshmallow.
    – MANI
    Aug 4, 2017 at 15:58

2 Answers 2

1

After the update.. the location of the lockscreen notification settings changed..

MIUI 10: It is located in Lockscreen > Advanced settings
MIUI 11: It's located in Settings > Notifications

If you're still stuck.. search for "notifications" from the search bar in the settings..

Hope it helps..

0

In settings, you can choose your notification settings when your device is locked. If you don't want to see anything at all, you can choose to do so (Don't show notifications at all). If you want to see just the notification but not content, you can use "Hide all sensitive data" or similar. You will see it pop up, but no one will be able to read content.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .