3

Problem

I have a Nokia 3 with stock Android installed, not rooted. Whenever the phone receives a notification, the screen turns on. I wish to change this, mostly because it drains the battery and causes me to activate the camera in my pocket.

In fact, I would appreciate if the screen only turns on when I press the power button.

Edit As was said in the comments, the Nokia comes with Android 7 (Nougat) installed.

What I have tried so far

  • Just for the record, I did browse through the settings of the phone looking for an obvious choice, and could not find any way to turn it off.
  • I have tried every possible setting for lockscreen notifications to no avail.
  • There is no Ambient display option in the Display section of my settings.
  • There is a screensaver option there, but whether it is on or off makes no difference.
  • After reading this, I tried using another text message application than the default. That also did not help.
2

I Googled around and am afraid this is the default setting for Android 7. People from all over the Internet are complaining about this. You can't simply turn it off.

However I found this trick working by entering Do Not Disturb mode. In Settings -> (Modes) -> DND there's a switch named Block visual disturbances. Turning it on and putting your phone into DND mode should work. As a side-effect, some other things are also changed in DND mode.

  • Frustrating, but I was soberly expecting this. I had hoped I had missed something. I will try both the DnD approach and also the macdroid autmation suggestion of yours from the comments and see what makes me least unhappy. – Jesko Hüttenhain Aug 4 '17 at 10:10
  • This sounds like the Ambient Display feature. Are you certain that it cannot be disabled? – Death Mask Salesman Aug 4 '17 at 10:55
  • @DeathMaskSalesman It can be disabled when compiling the ROM, which is OT here. As far as I've found on Google there isn't a user option to disable it. Custom ROMs may provide one but that highly depends. – iBug Aug 4 '17 at 13:34
  • @iBug That's the catch. While LineageOS 14.1 allows to disable the setting, I was unsure about other Nougat flavors. – Death Mask Salesman Aug 4 '17 at 13:42
  • @DeathMaskSalesman OnePlus 5 with stock OOS. No option available. – iBug Aug 4 '17 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.