0

I've noticed a very strange behavior on my phone. Every time I move out of my house walking or in the car it starts to get hot and drain battery. Google play services become on top of consumption.

I have location on saving mode, location sharing disabled and location history disabled as well. Consumption when quiet is awesome (1% per 2 hours)

Any tip? Not going out isn't an option haha

  • Is your WiFi scanning enabled? what's the Android version? – beeshyams Aug 4 '17 at 13:28
  • Android 6, wifi is on but I think scanning is not (I disabled the option of notify open networks...) do I have to modify something else to disable it? – jevora Aug 4 '17 at 13:30
1

I actually use High location accuracy mode, but also keep all background location using app disabled via greenify. I think the real problem is that your device apps checks location and use other sensors too much. For e.g. Maps, Fitness apps and such other apps might be responsible. Download greenify and try it. It should show which app run in background and for what purpose.

  • Thanks for the advice, I'll give it a try but I normally use greenify with donation pack and it seems not to be very useful. In my case, I don't even have Maps installed so I would not know what to greenify. However, I'll try to investigate in that direction. – jevora Aug 4 '17 at 7:32
  • Greenify seems to mention that Google photos and mifit may device slow. I hibernate photos but not mifit (I use it). Do you think photos could be causing such battery drain when out of my home? – jevora Aug 4 '17 at 14:43
0

as the above answerer pointed out, an app that will hibernate other apps when screen is closed like Greenify will help prevent unnecessary background services running. but if I'm not mistaken Google services cannot be controlled with Greenify and hibernated . what you can also do it turn off mobile bandwidth usage in the background. this is a setting available on Android 6. Plus or it may even be before that I'm not sure. it is under mobile data traffic >> restrict background data. you can restrict at phone level which did not work well for me because my phone would go to sleep for a long time and I found it hard to wake it up or you can disable at app level .This works best for me. another option to try out is under developer options limit background process limit to nothing which means there is no background process or you can restricted to only one or two background processes

  • +1 ill try it but I guess it will work with WhatsApp and other communication apps? – jevora Aug 4 '17 at 14:42
  • yes... in my case it has worked well – user1874594 Aug 4 '17 at 15:07
0

I fixed it. It seems that Macrodroid was causing the battery drain. I had some rules related to be connected/disconnected to the wifi of my house. Not sure why but sometimes, when out of my house, Google Play Services started to drain battery crazily. As I knew Macrodroid had also "location" based rules, I decided to remove it and since that I haven't had this battery drain again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.