Im using a rooted Samsung Galaxy ACE with 2.3.4. I installed link2sd and I have a 1Gb ext2 (I tried with fat32 also with the same result) partition. After starting the app and selecting the partition I get this error:

Mount Script cannot be created 
Mount: Invalid argument

Any ideas?

  • Are you rooted? – roxan Jan 10 '12 at 8:12
  • I am. Editing question to clarify. – Chepech Jan 10 '12 at 14:00

do you have busybox installed? Open up terminal emulator and type busybox if a load of stuff comes up on the screen, then you have busybox installed.

Next, type mount into terminal emulator, if a load of crap comes up then you do have mount installed.

Otherwise, download the BusyBox Installer app on market, and download an older version of busybox. The same if you already have it installed, as the newer versions have loads of errors.

If that doesn't work, then I suggest emaailing the developer with a bug report.

|improve this answer|||||
  • I don't think I have busybox. Do you suggest any version in particular? – Chepech Jan 10 '12 at 14:02
  • 1
    Ok, so I fixed it, my issue, besides the missing BusyBox, was that I mistakenly created it as a logical, so it couldn't mount, I changed it to primary and it did the trick. – Chepech Jan 10 '12 at 17:27
  • In my rooted LG P500, I was using Link2SD with ext4 partition quite well until I tried a custom ROM installation and reverted to backed up stock ROM. Now I am unable to mount the ext4 partition with an error "mount: No such device". Installing BusyBox 1.17.2 which didn't change this situation. :( Any further ideas? – Narayanan Mar 21 '13 at 11:25

You don't need busybox. Custom or stock rom has this issue. Backup up memory card and repartition from CWM recovery mode.

|improve this answer|||||
  • 1
    I agree that busybox is not required for Link2SD to work (at least in my case: Lg P500, rooted with stock ROM) and repartitioning with CWM is helpful, especially after a nandroid restore (again in my case). – Narayanan May 9 '13 at 7:40
  • BusyBox was in fact not needed, my particular issue was caused by the type of partition I was trying to use, as stated above. – Chepech May 10 '13 at 17:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.