I'm trying to replace the stock ROM on my OnePlus 3 in an attempt to find out if another ROM has fixed a set of really annoying bugs present in stock. My phone is running the latest OTA from OnePlus (ONEPLUS A3000_16_170610).

I've followed the following steps:

  1. Flash TWRP and SuperSU. Reboot several times.
  2. Disable lockscreen security.
  3. Boot to recovery and do a full backup.
  4. Reboot and copy new ROM and Gapps to /sdcard.
  5. Reboot to recovery.
  6. Wipe dalvik, system, data, and cache.
  7. Attempt to install the ROM. At this point, I get the following error:

    Checking for MODEM build time-stamp 2017-06-27 21:43:31
    assert failed: op3.verify_modem("2017-06-27 21:43:31") == "1"
    Updater process ended with ERROR: 7
    Error installing zip file '/sdcard/RR-N-v5.8.4-20170806-oneplus3-Official.zip'

This example is using the latest Resurrection Remix ROM, but I've also gotten the exact same error from the latest LineageOS.

What's wrong?

  • I have also got this error 7, while installing latest RR(Aug08) nightly. It may be due to less space for /system partition. Please check system partition using this app DiskInfo(play.google.com/store/apps/…). On my device, it got solved by increasing /system partition. Some solutions are found on xda: forum.xda-developers.com/oneplus-3/help/…
    – Rahul Gopi
    Aug 11, 2017 at 5:28
  • Thanks. However, there appear to be many causes for error 7, as well as many error descriptions. The one you linked to appears unrelated. Aug 11, 2017 at 16:59

3 Answers 3


This will likely be closed as off topic, but twrp is telling you exactly what's wrong. Your modem does not match the accepted one that you should use. Usually means you need to update firmware (bootloaders, modem, any vendor partitions etc).

  • My modem is fully stock, so it can't possibly be wrong. Aug 12, 2017 at 13:01
  • You misunderstand, I'm not claiming it a modem one, I'm saying it likely a older one that no longer works. Regardless the problem is your firmware doesn't match what the rom dev for that device says it should be. I know OnePlus roms usually run with latest OnePlus beta build sources/firmware. Look at xda see if there is an updated firmware zip. Aug 12, 2017 at 13:33

TWRP error codes are useless The message about the error is what helps

This is what leads to the exact error

assert failed: op3.verify_modem("2017-06-27 21:43:31") == "1"

I link you to the relevant XDA thread where you can flash the proper firmware and modem https://forum.xda-developers.com/oneplus-3/how-to/op3-flashable-firmware-modem-zips-t3816066

Be very careful! Upgrading the firmware on an op3 will make the TPM destroy the encrypted private key used for decryption if the bootloader is unlocked so if you're encrypted it is a good idea to backup all data before you attempt to upgrade the firmware

There is also a high chance that your older recovery will no longer boot after upgrading the firmware so you must upgrade your recovery before you attempt an upgrade


You have to flash kernel first given in the following xda tread !!! Without flashing the custom firmware you cannot flash the rom !! Resurrection remix uses its custom kernel

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .