1

I use my phone (a OnePlus 3 running the stock ROM and Android 7.1.1) as my primary internet connection. This means that I make heavy use of wireless tethering, especially for work. The trouble is, whenever my phone rings, regardless of whether I answer it, wireless tethering gets disabled. If I use USB tethering, I have no such problem, but wireless is much more convenient.

Is there any way to prevent wireless from being disabled? I previously came across this answer, but it doesn't apply to me. I've never had a phone which was unable to simultaneously use phone and data. When I'm on a call, I can enable wireless tethering no problem. It just gets disabled for no good reason whenever I receive a call.

Failing my first question, I would also accept a method to make my phone completely ignore incoming calls during specified times, so that they couldn't disable tethering, so long as I kept internet access and text messaging.

EDIT

In response to comments, let me point out that the issue is not the connection technology (WCDMA, VoLTE, carrier support, etc.) This is absolutely impossible, since the fact mentioned above that I can manually re-enable tethering while on a call, coupled with the fact that I have full access to data while on a call, disproves any such theories. This is why I started a new thread instead of using the old one I linked to above.

  • It has two SIM slots, but I only have a single SIM for it. I see no reason to pay for two phone subscriptions. – Scott Severance Aug 11 '17 at 17:29
  • See: forums.oneplus.net/threads/… – xavier_fakerat Aug 11 '17 at 17:56
  • @xavier_fakerat, see my edit above. This has nothing to do with the phone's ability to simultaneously handle voice and data. – Scott Severance Aug 11 '17 at 18:05
  • Ok I apologise for misunderstanding you – xavier_fakerat Aug 11 '17 at 18:16
  • For second part (ignoring calls ) you could try Macrodroid. Trigger: call incoming> any number; Action;: call reject:; constraints: WiFi hotspot State > WiFi hotspot on. If this solved your problem and you want me to post this as an answer, please tag me to post as I would be logged out – beeshyams Aug 12 '17 at 1:44
0

On my LG K20 running 7.0 I have “Do Not Disturb” under” Settings > Sound & Notification”. With that turned on, incoming calls do not turn the WiFi hotspot off. I just now tested it to make sure. I can leave it on until I switch it back off again myself or I can set a timer that will turn “Do Not Disturb” off after a specified length of time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.