0

I believe I can access the files on my Android mobile from my Linux Desktop if I turn on 'usb tethering' on my mobile. However, when I do it, nothing appears on my file manager. I am using Debian9 Linux and I have tried it with KDE desktop and Dolphin file manager (where I also checked 'Network' in places) and also on LXDE desktop with PCManFm and Thunar file managers.

On checking dmesg, I see following at messages:

...
[ 1400.700600] usb 1-1.4.3: new high-speed USB device number 13 using ehci-pci
[ 1400.810883] usb 1-1.4.3: New USB device found, idVendor=1ebf, idProduct=6880
[ 1400.810886] usb 1-1.4.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1400.810888] usb 1-1.4.3: Product: Android
[ 1400.810890] usb 1-1.4.3: Manufacturer: Android
[ 1400.810891] usb 1-1.4.3: SerialNumber: 3a2e77f
[ 1400.819857] rndis_host 1-1.4.3:1.0 usb0: register 'rndis_host' at usb-0000:00:1a.0-1.4.3, RNDIS device, 32:04:36:81:21:ff
[ 1400.842696] rndis_host 1-1.4.3:1.0 enp0s26u1u4u3: renamed from usb0
[ 1400.878144] IPv6: ADDRCONF(NETDEV_UP): enp0s26u1u4u3: link is not ready

How can I access files on my mobile with usb tethering? Thanks for your help.

0

Tethering doesn't provide access to device's storage. It simply establishes a network between the host (mobile) and client (PC) where PC can access internet, if available. If you need storage access, try MTP or ADB or network based file access (WebDAV, FTP, SSH, etc.). I do not know much about setting-up MTP on Debian but the rest alternatives are covered in my answer here.

  • I tried mtp-alternative usb drive but Debian Linux is not connecting to dav://192.168.42.129:8081/ . Where could be the problem? – rnso Aug 13 '17 at 12:06
  • I really do not know. Could be a problem with how your Debian box connects to a WebDAV server. I just tried it again on my Android 6.0.1 and Slackware 14.2 (KDE) and works just fine. – Firelord Aug 13 '17 at 12:11
  • Mine is Android 4.4.4. Can this be done from command line? Then I could see the error messages. – rnso Aug 13 '17 at 14:05
  • It works from Windows but not from Linux. – rnso Aug 13 '17 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.