2

I wiped, formatted, and then installed the latest Lineage OS for my device.

When I install Firefox, before I ever browse anything and after turning search suggestions off, I see URL suggestions whenever I begin to type an address.

For example, if I type 't', the URL bar suggests twitter.com; 'ta' target.com; 'te' telegraph.co.uk; 'ti' ticketmaster.com; 'to' toysrus.com; 'tu' tumblr.com; 'aa' aa.com; 'ac' accuweather.com; etc.

I cannot find where to tun off these suggestions, and there is no reasonable way to avoid these suggestions, and 100% are completely useless for me. I want my URL bar to only offer me the suggestions of sites that I have actually visited, not all this garbage noise that Mozilla is puking into my face with.

8
  • We can't answer "why", though it seems obvious that other people might find them useful. Generally they're done via a lookup service, not built in. Commented Aug 13, 2017 at 18:34
  • @MatthewRead Can you please kindly review my edited title and inform me as to whether it meets your approval? Can you graciously extend the time to inform me what a "lookup service, not built in" is?
    – Paul
    Commented Aug 13, 2017 at 18:55
  • Paul: the websites it suggests, have they been visited by you in the past using that browser?
    – Firelord
    Commented Aug 14, 2017 at 18:08
  • 2
    @Firelord No, I visited zero sites before receiving those suggestions.
    – Paul
    Commented Aug 14, 2017 at 19:27
  • this site seems to at least acknowledge the fuctionality in a mozilla product. It didn't help me, unfortunately, but it seems like a step toward finding a solution.
    – Him
    Commented Feb 19, 2020 at 14:53

2 Answers 2

2

It's impossible without disabling autocomplete completely and Mozilla maintainers refuse to change it, see this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1267208

1
  • 1
    I'm convinced someone is paying them to put it there. It is the same effect as an advertisement.
    – Paul
    Commented May 13, 2020 at 11:03
1

Try editing the firefox configuration manually; it worked on my phone.

1.Type about:config in the address bar.

  1. Set "browser.urlbar.autocomplete.enabled" to "False".

  2. Type "ta" in the address bar. It should no longer autocomplete to "target.com"

4
  • 2
    This eliminates the autocomplete function. I just want to make the ads go away.
    – Paul
    Commented Aug 13, 2017 at 23:22
  • But that is exactly what you wanted i.e. for Firefox to stop suggesting URLs. No mention of ads in your question.
    – tony
    Commented Aug 15, 2017 at 5:03
  • 1
    I stated that I cannot find where to turn off these suggestions, indicating that I don't want to turn off all suggestions.
    – Paul
    Commented Aug 15, 2017 at 21:02
  • 2
    It would be nice to have a way to turn off only the `default' suggestions.
    – Him
    Commented Feb 19, 2020 at 9:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .