On eBay I picked up one of those cheap Chinese 7" Quad-Core AllDayMall A88s tablets for $25, WiFi-only.

enter image description here

When it comes on all is fine unless you try to open the browser. Then things start popping up that are quite unsavory. So I did a factory reset but it seems all that junk is built in.

I sure hope the kid's version doesn't have this firmware. There are some things you simply cannot un-see. Perhaps the pink ones are different.

Going into settings, apps, I was able to identify and stop a lot of it. But as soon as I opened the browser it went nuts showing more.

I got the unit to tell me to sideload a file via the menu that comes up when you hold down-volume and power. Cool. Following somebody's advice I installed the Android SDK to do it. But then found out that all I needed was the ADB Platform Tools with adb.exe. (Don't need the SDK at all it turns out)

So I plugged it into my Win7 machine which installed an Alcatel driver for it. I could see it in device manager.


adb device -l

gave me a long number then the word sideload (instead of the name of the device)

Pushing on, I found out for positive certain that it needs Alldaymall-A88X-android 4.4.2-bsf.rar and thought I was on a roll.
All I had to do was download the file, unRAR it to get the ROM image, then refresh the ROM with the command it was asking for:

adb sideload Alldaymall-A888x-etc-etc

-- But no, the download link is to a dropbox account that says not found.

It can easily be set to receive a sideload. Driver installed and working. Daemon program installed and working on the PC to handle the work. Necessary file identified. Seemed like a slam dunk. But no. Not available. Dead End. <sigh> Lots of smoke but no fire.

Switching gears, I used the Windows version of one-click KingoRoot which said it succeeded. Went to the play store to get Kingo SuperUser and a good file explorer so I can seek and destroy.

During the process of setting up for Play Store it wants to log in, so I let it connect to WiFi. Big mistake. I never even got to the part of credentials with Google. Pop-ups on every screen and unresponsive touch panel. OK, reboot.

I installed a mouse via an adapter into the USB port but it worked the same as the screen. Just fine. Until it didn't.

Rebooted; Shut off WiFi then with the stock file explorer I went into the DCIM directory and under Camera there were a bunch of porn photos and a video, which I successfully deleted.

I am not sure how to find the built-in junkware so I can remove it.

I made some headway but this has taken hours. So now I turn to Android Stack Exchange to get some expert opinions. You can see that I have done my homework before asking for help.

Last thing to do tonight is to uninstall the SDK.

The question is in the title: Now what?

  • 2
    Oh, this device. Oh no. As you guessed, the bloatware is preinstalled, but I don't remember getting adverts like that - I was getting adverts for Chinese dating sites, and occasionally some form of eBay alternative. Anywho, Kingroot comes with a bloatware remover, and root means you can go through and delete some things. If I still had mine, I'd walk you through it.
    – Dan Brown
    Commented Aug 15, 2017 at 9:48
  • 2
    +1 for your homework. Now, can you try a different browser and see if it still downloads and shows all that crap? If it does, please follow my answer.
    – Firelord
    Commented Aug 15, 2017 at 12:39
  • Yes, "this device," @Dan - I thought it made sense to get a cheap one first. Now I have a RCA Viking Pro and really like it. Yes, the junk is coming from "Porn Club" software which is linked to "Monkey Test" and others that do coupons. Today I'll take a closer look into the file system using the built-in file manager. Hopefully can find a directory of all the built-in stuff and get it all in one swell foop.
    – SDsolar
    Commented Aug 15, 2017 at 16:21
  • Thank you for that tip, @Firelord. I like your instructions about how to use adb. As for a different browser I don't know yet whether any others are installed. Will check that out this morning. I don't yet know if I can get Play Store up and running. Just that I can stop apps that I know are obviously bad. The screen I found seems to be expecting just a adb sideload. I haven't yet tried adb without that screen up. Will try that, too. One thing I did notice is that in the "downloaded" software section are three programs. They appear to be more designed for phones than tablets.
    – SDsolar
    Commented Aug 15, 2017 at 16:26
  • I do see the Google browser is there, and no problems with it. The three "downloaded" apps are dragonphone, dragonfire, videotest. Once I uninstall them, I can stop the processes of porn club and love finder and they do not automatically relaunch. Ah, this is progress.
    – SDsolar
    Commented Aug 15, 2017 at 16:58

1 Answer 1


After rooting it and getting most of the software stopped it settled down a lot.

Google browser came up without incident.

A couple of coupons came on screen which closed when I clicked on the little x in the corner.

But then, as soon as I tried to get logged into Play Store it froze up and put a white low-res band across the bottom that said EXIT on the left, with a large low-res X on the right. At first I just waited then tried again, but no mouse action would make it do anything.

When I hit the X on the bottom banner, it rebooted and restarted all the bloatware again...

After several rounds of this I tore it apart and removed the Lithium battery so I could just throw it in the trash.

Then, having learned about KingoRoot, I downloaded it into my good RCA Viking Pro, and rooted it successfully.

Downloaded the SuperUser browser which is nice, dual pane.

Then as I browsed around I wanted to see system text files so I downloaded QuickEdit for that. It works well.

Then I downloaded the Qute SU Console and it would handle simple commands like pwd and ls and such. It even included a bash editor which allowed simple scripts to work. There was no sudo command so I couldn't change most of the system from read-only to writeable. Maybe that is just the nature of ROM.

Manipulating things on the sd card is easy, of course.

Downloaded a VIM program which worked.

So this hasn't been a total waste. It was a learning experience.

Meanwhile, the answer to "what now?" has turned out to be to use Google and learn all I can - and throw the darn thing away. It is absolutely worthless. I suppose I got $25 worth of learning out of the experience so it isn't a total loss. Chin up and all that.

Now I need to figure out how to dispose of the 2200ma Lithium battery. I live out in the desert and am tempted to start a campfire and use it for fireworks, but perhaps the recycling center is better for the environment.

Thank you for the comments along the way.


  • What an adventure. It's got me all curious what exactly the point is of selling these. Do people really want to knowingly pay money for something that promotes this junk and isn't otherwise useful? Commented Aug 18, 2017 at 3:25
  • In the end they got my money. I complained to them about the short battery life (not realizing it was because it was constantly downloading more and more porn, filling up the screens with icons for the Love Connection. None of them worked, either, because it was so busy adding more until I did the factory reset and didn't give it a connection.) They wrote back and assured me the battery was a 2200ma (which it is). I should have pushed harder about getting a refund. eBay would have forced them to do it. Now it has been too long.
    – SDsolar
    Commented Aug 18, 2017 at 5:24
  • And no, @Twist, I certainly did not want to pay money for something that promotes this junk and isn't otherwise useful. Hah! Actually, since I'm a dad it worries me that kids might buy these. The ad on eBay looked great and it was quite inexpensive.
    – SDsolar
    Commented Aug 18, 2017 at 5:26
  • I wasn't supposing you wanted to buy what you ended up with. It's a shame such a thing exists. Commented Aug 18, 2017 at 12:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .