This application is sending a lot of spam to my phone recently, two or three times a day. I deactivated broadcast messages, tried converting USSD pop-ups into notifications to avoid being interrupted (didn't work). Basically, everything I tried didn't work, so now I want to remove it from my phone. Is it possible to do it without root, with ADB or something? I'm not a power user but I have used ADB to give permissions to some apps before.

  • This might help: How to Uninstall Carrier/OEM Bloatware Without Root Access
    – Gokul NC
    Commented Aug 19, 2017 at 9:19
  • @GokulNC Just as a heads-up, SIM Toolkit is installed on /system even on LineageOS, hence it doesn't seem to be related to carriers.
    – Grimoire
    Commented Aug 19, 2017 at 16:37
  • @DeathMaskSalesman Though the title of the article reads 'Carrier/OEM', they mean all the system apps.
    – Gokul NC
    Commented Aug 20, 2017 at 7:41
  • @GokulNC Of course. Mine was just a precisation.
    – Grimoire
    Commented Aug 20, 2017 at 14:37

3 Answers 3

  1. Connect Your Phone to PC Using Data Cable.
  2. Turn on USB Debugging
  3. Setup ADB Connection
  4. Type

    adb shell
  5. Hit Enter and type again this

    pm uninstall -k --user 0 com.android.stk


    pm uninstall -k --user 0 com.android.stk2

Application Remove Example Image

enter image description here


An app can be disabled without root by running

adb shell pm disable-user com.android.stk
  • I've prefixed adb shell because pm commands usually are not available to untrusted users/apps.
    – Firelord
    Commented Oct 15, 2019 at 13:12

If the app in question is stored in /system and it cannot be disabled then it's impossible to remove/disable without root. Android simply doesn't allow "user" to mess with system apps. That being said without knowing device specifics I've seen some cheap chinese phones include adb root which is a somewhat watered down root specific to adb (usually only for debug builds). To test have adb working on a pc and while connected to device and run adb root. If it works it should restart adb service with root perms. But again this is a longshot.

Assuming you get root (one way or another) and you know the name of the app in question find it in system/app or system/priv-app. Mount system as rw and remove the app (I'd recommend copying it to your pc as a backup just in case something breaks).