I have a Huawei X3 (U8510) which I've purchased for testing Android applications I'm developing. I'd like to root this, but as I've not had any experience with rooting Android handsets, its something I'm approaching with some caution.

What is the recommended way to root the X3? I've found mention of a Windows app called SuperOneClick, which looks like it may be useful. My development machine is a Mac, but I'm not adverse to using Windows apps to do this if its easier.


2 Answers 2


Full rooting instructions for Huawei IDEOS X3 (U8510) are posted on this thread over at XDA:

  1. Download the Automatic Root Enabler for the X3. For more recent versions I suggest checking original thread and the forum it's in as I may not be able to update this thread all the time.
  2. Install the latest USB drivers for the X3. Search for the latest version of "HUAWEI Android Phones USB Driver" from the Huawei Downloads site.
  3. Turn on USB Debugging from Settings -> Application -> Development on the X3.
  4. Connect the X3 to your PC via microUSB.
  5. Run the Automatic Root Enabler and it should start rooting your phone automatically.
  • I'd love to accept this answer, but I've encountered these instructions already, and have been unable to find a valid download link for the Automatic Root Enabler app mentioned in the steps. Are you able to provide this information?
    – Cleggy
    Commented Jan 18, 2012 at 21:05
  • 1
    Looks like that one was taken down. Try links from this post: android-hilfe.de/root-hacking-modding-fuer-huawei-ideos-x3/…
    – Chahk
    Commented Jan 19, 2012 at 0:01
  • Thanks, we're getting closer. However when I run Automatic Root Enabler (v1.1) it seems to be stuck at the waiting for device stage. The phone has initiated a reboot, but is stuck at the Huawei logo and doesn't progress from there. I'm currently attempting this on a Windows VM hosted on my Macbook Pro, so if I have no joy, I may attempt it on my daughters Windows netbook instead, just so I can rule out any VM related issues.
    – Cleggy
    Commented Jan 19, 2012 at 1:32
  • 1
    Try a native Windows host. Also, make sure to check your Windows drivers and don't be afraid to give it a few tries.
    – Mr. Buster
    Commented Jan 19, 2012 at 1:35
  • It seems to have worked on my native Windows machine, but only after I prompted Windows to find drivers from Live Update, after failing to successfully install the drivers when the phone boots into Fastboot mode. Thanks for all the help. I'll mark this answer as the correct one, and will award the bounty.
    – Cleggy
    Commented Jan 19, 2012 at 2:08

I found this really good tutorial, but its german ... I translate:

  1. prepare phone, go to settings > apps and disable "fastboot".
  2. shutdown phone, completely (if you want to be safe, remove battery and plug it in back)
  3. Boot into fastboot mode (press and hold VolDown + Power)
  4. plug usb to phone, windows will show up a new device. If the driver is not installed properly, install it via device manager (Download driver here). Now the device should show up as Android Sooner Single ADB Interface
  5. Download this and navigate to RecoveryClockmodByZaDkYn and start Instalador.bat
  6. Now open a command prompt, press any button. Now the progress is started. If its finished, press any button again.
  7. Now you have ClockWorkMod installed, download this file, copy It to your sdcard. Boot into CWM, select install zip from sdcard and chose chose zip from sdcard select su.zip and press power to flash it (you can navigate in the cwm with volumeDown and Up)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .