0

I am having trouble manually setting the date on my android emulator.

I am using an ARM AVD which is running on a Windows 10 Virtual Machine (no Intel HAXM available), and the emulator is being run with the "-gpu swiftshader" option.

I tried setting the date both from the Android UI (the settings menu) and from the shell (adb date -s command with root privileges) with no success. The date keeps beeing stuck on 1/1/1970.

I Also tried changing my AVD's and the Android versions. I tried it on Android versions 2.3, 4.2, and 4.4. None of them worked.

What might be the problem? Any ideas?

0

I use Eclipse Oxygen.3a Release (4.7.3a) I had the same problem. I resolved checking "Snapshot" in Emulator Options (in Android Virtual Device Manager). When you launch the Emulator you'll see your current date and time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.