0

I recently applied the Android Nougat 7.1.1 update to my partner's Wileyfox Swift. This update replaced Cyanogen with a more stock install. Since the update, mobile data no longer works. Symptoms:

  • In the status menu, it says "Emergency Calls Only", but the phone can in fact make calls and send texts as normal.
  • In Systems > SIM cards, it shows the SIM card for Three UK ('3') installed in slot 1.
    • Under "Preferred SIM for", it says "Mobile data: Selection required", but this item is greyed out so no selection can be made. (For Calls and SMS messages, it correctly shows that the '3' SIM is selected.
  • In Settings > Data usage, under '3' it shows that mobile data is enabled.
  • In Settings > Mobile network settings > APNs, it shows the '3 UK' APN selected. APN details are as specified on the three.co.uk website.
  • In Settings > About phone > Status > SIM Status, it shows the network (3), Signal strength (-73 dBm 20 asu), Mobile network type (HSPA), Service status (In service), Mobile network status (disconnected) and My phone number (Unknown).

I have tried rebooting, as well as booting without sim then rebooting with.

What could be preventing mobile data from working after an update to 7.1.1?

0

Overall it looks like a issue related to the kernel. I would say it would be possible to fix this just by installing another version and/or install a custom kernel which very likely fix this issue if it is related to the kernel. While you are trying this I would also recommend contacting the developer and reporting this issue. Also try another Simcard slot if you can. I had a similar issue sometimes with my phone too but a reboot fixed the issue usually.

0

I managed to make it work, buy following the instructions below:

  1. Wiped the cache (not sure if this is related or not, but I did it)
  2. Removed All APNs, disable mobile data, Reboot the phone
  3. Create a new APN and set "Bearer type" of the APN to "GPRS,LTE,EDGE" and un-checked the first item "unspecified", and save the APN.
    1. Reboot the phone, Enable mobile data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.