0

I had recently had a hand on my friend's Moto X Force 1580. The phone works on Android 7.0. I went through the web and found out some guys claiming to make Moto X Style to work on VoLTE. I followed the same procedure but had no luck. Following is the procedure that I went through.

  1. Dial *#*#4636#*#*
  2. A hidden menu would start, select "Phone Information"
  3. In this window, there is a switch that says "VoLTE provisioned". This by default is off, turn this on
  4. Restart the phone.

I tried this number of times, but it turns back off every time.

Can anyone help?

0

2 Answers 2

1

Basically what you want is to keep your phone in 4G LTE while making/receiving a call, but it is dropping to 3G/2G, right?

I have worked in 2 big Android phone manufacturers on Software teams. And both had the same policy. It's too risky to enable any feature on an Smartphone without tests.

And VoLTE/VoWifi/ViLTE and now VoNR (5G) are all enabled/disabled carrier by carrier. One of the reasons your phone has VoLTE disabled for you carrier could be:

  • You bought the phone in a different country than where you are using it.
  • When you bough the phone, you carrier didn't support VoLTE at the time. And the cost to test and enable it now is too high for a phone that is not been sold anymore.

So you could try to put a SIM card of a different carrier to see if VoLTE is enabled. Try the biggest carriers of your country.

There is a service named "carrier_config" that handles all IMS enablement. You can type:

$ adb shell
$ dumpsys carrier_config | carrier_volte_available_bool

To confirm the parameter. You'll probably get: carrier_volte_available_bool = false

But unfortunately I don't know how to set it to true using ADB. I only know changing the source code.

0

Your phone doesn't support VoLTE

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .