I've created a MIUI account through my Redmi Note 4 and applied for permission to unlock the bootloader through the official Xiaomi unlocking link.

The problem is that after I enter my phone number so that they send me the code which I'd use to apply for the permission --which takes a lot of time to receive but I was patient and waited-- it gives me a pop-up message in Chinese in which it's roughly translated to: "You have reached the limit for this IP".

Please keep in mind that I haven't signed up with many accounts from the same PC. I've tried another email, phone number, and a new MIUI account from a totally different PC and it still gave me the same pop-up message.

I really want to root my device. Please help!

  • 1
    "another email, phone number and a new MIUI account from a totally different PC" but still under the same network? Won't help when it's saying "reached the limit for this IP"... Probably want to try doing this from elsewhere.
    – Andy Yan
    Aug 21, 2017 at 1:25
  • By "same network" you mean same internet provider? or same mobile network provider? coz if it's the latter then no, i've used another number with different network (aka different mobile network).
    – Leona
    Aug 21, 2017 at 10:43
  • That's weird indeed. At this moment I'd consult people at MIUI forum for help...
    – Andy Yan
    Aug 21, 2017 at 11:36

1 Answer 1


It is a known fact that ISPs are allocated a bunch of IP addresses which are then dynamically distributed among the public. So, every time you connect to the internet, it is possible you are allocated a different IP address, and sometimes it might be the same (try whatismyip on your browser to see your IP address). So, try the procedure using mobile data.

If it still doesn't work, I would like to suggest to you an unofficial method mentioned in XDA and I request you to go through the entire thread.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .