0

I have successfully installed TWRP 3.1.1 on my HTC Desire 510. I have rooted the phone with a modified ROM (so I think). But supersu keeps complaining: "Die SU-Binary muss aktualisiert werden. Fortfahren?" (i.e. super-su binary must be updated. continue?) If I continue, I can choose between "normal" installation and "using TWRP/CWM" for installation. Neither works.

  • "Normal installation" yields "SU update unsuccessful" and leaves me a reboot or a link to some tutorials.
  • "Installation using TWRM TWRP manages to boot directly into TWRM TWRP (yeah!), but does not change anything. super-SU comes up with the same message after reboot.
  • I also downloaded the last super-SU zip and installed it from TWRM TWRP, but with the same outcome.

I have some suspicions.

  • the phone might not be rooted properly? I unlocked its bootloader according to the HTC standard process (fastboot and token generation on HTC's website). This at least allowed me to install TWRM TWRP and a modified ROM. I checked root access with two different root checkers and they told me, my phone was properly rooted
  • supersu is somehow broken?
  • Sorry that was a typo. I corrected it transparently. TWRP makes more sense, doesn't it? I'll look up the supersu version I used later, as I can't look it up now, but I downloaded it last friday, and I think it was supposed to be the latest. – Ariser Aug 22 '17 at 5:46
  • How do I identify v2.79 version 3? I found "SuperSU-v2.79-201612051815" for download. Is that the right version? – Ariser Aug 22 '17 at 10:56
  • Ok, downloaded it, installed via TWRP, but the superSU app keeps complanining, that I "must" update the binary. Perhaps I just should ignore that? – Ariser Aug 22 '17 at 12:38
  • Let us continue this discussion in chat. – beeshyams Aug 22 '17 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.