-1

So I was exercising hard and my phone fell ackwardly from the elliptic, the phone died, when I picked it up, my screen was full of lines. The glass does not seem broken but what is under the glass seems broken.

The screen shows full of crazy lines, they move a little, it seems to be a spaced out version of what the phone would normally show.

So in the screen I cannot see much, also I cannot seem to interact with the screen anymore, I suspect that the screen is also sending many random touch signals make the phone go crazy and make old modem noises when booting it normally.

So my hope is to simply connect this phone to my Ubuntu with adb so I can regain control and get my files.

So far I have discovered the following.

I can turn off the phone by holding the power button a long time.

After that I am able to boot it in a way that fastboot can see it and control it by holding either volume down + power or both volume up and down + power and releasing as soon as *something appears on the screen.

From there I can mess around with fast boot.

at first I had:

sudo fastboot oem device-info ... (bootloader) Device tampered: true (bootloader) Device unlocked: false (bootloader) off-mode-charge: true OKAY [ 0.003s] finished. total time: 0.003s

And I was not able to flash twrp recovery

I was supposed to be able to unlock it with fastboot oem unlock but I was just hanging at waiting for device :( however I understood that after the oem unlock there is a comfirmation on the phone. I had to use the volume keys and go down a few times and press power, it was a pretty blind not easy operation really but it actually worked!

So now I get:

sudo fastboot oem device-info ... (bootloader) Device tampered: true (bootloader) Device unlocked: true (bootloader) off-mode-charge: true OKAY [ 0.003s] finished. total time: 0.003s

(houray)

and I was able to flash twrp on my recovery partition with

fastboot flash recovery twrp-3.1.1-0-hammerhead.img

(this is supposedly the correct version of twrp for my Nexus 5)

target reported max download size of 1073741824 bytes sending 'recovery' (14604 KB)... OKAY [ 0.674s] writing 'recovery'... OKAY [ 1.153s] finished. total time: 1.828s

bang!! seems to work, I can flash paritions there should be a way to salvage my file!!

and thats how far I have gotten. Now when the phone boots the crazy lines/colors seem to be different but I cannot seem to go any further. Still when I type

sudo adb devices

I get nothing.

Can anyone help me out on this?

Is it possible that twrp boots but wont work properly since my phone sends plenty of touch signals through its broken screen? Can I use the physical buttons to do enable adb in twrp?

I should now just have to do

fastboot reboot

(possibly holding certain buttons, I pretty much tried them all)

and twrp should boot and I should be able to see my phone with adb. but I dont...

sudo killall adb ~/Desktop$ sudo adb devices * daemon not running. starting it now on port 5037 * * daemon started successfully * List of devices attached

does anyone have any insight as to how can I get this phone connected to adb.

I think twrp is booting but its hard to tell with that crazy screen. Is there something I need to do with the physical buttons?

well Im not sure if I should post this anymore because I just found my answer it seems. For the good of humanity and others in need I will post it and the baby Jesus shall decide what happens with it.

So I was finally able to get in adb!

It was all about that step where it said you need to hold some buttons when you boot. Well I was holding just volume buttons, turns out I had to hold power too (for some reason I though since it was already rebooting only the volume keys would send the necessary signal)

so I reflashed twrp with fastboot, held basically all the keys (vol up and down + power) and did fastboot reboot. Then suddenly it booted and right away my Nexus drive appeared on my computer, accessible. I was like holy hell lets get my files now!! But I couldnt see them I was in what seemed to be a blank phone with empty Download, Music etc folders....

Turns out all my files were gone. Doing adb shell I could linux into the phone and a df -h showed my main partition 12G was only 6%, thats uncharacteristic, my phone was always so full!!

It appeared that at some point I wiped the phone. Im not sure actually but I suspect it might have been when I did fastboot oem unlock, doesnt that wipe your phone for security? Either that or I accidentally picked the factory reset while trying to navigate in the bootloader without seeing anything.

Oh well I didnt have much on there anymore. Only lost about 2 weeks of Exiled Kingdoms gameplay and will need to redownload a few books/songs...

Although I found my answer, Im going to post this in case it can help someone.

Cheers!

(note I had to yank out all the links to other articles that were helpful because stack exchange says my post looks like spam..)

=========EDIT

I was wrong about 1 thing. I dont need to hold the power button the procedure to be able to connect adb on my phone with broken screen (cant see except vague colors, cant touch) and usb debugging disabled, here is the exact procedure now that I have done it a few times:

(note that I first had to unlock the bootloader, how is explained above)

-power off holding power button longtime (USB must be disconnected for some reason) until it stops throwing random vibrations -boot holding vol down and power, release at first thing poping on screen, then youre in fastboot -sudo fastboot devices (you should see a device) -sudo fastboot flash recovery twrp-[correctversionforyourphone].img -then hold power down and type in sudo fastboot reboot -release at first thing on screen -then you get in a screen where you need to select recovery, this video helped me see what the menu looks like: https://www.youtube.com/watch?v=ku3xF8gh22M basically there are 4 options and the 4th is recovery so I guess you could just press vol down 3 times and then press power to boot in recovery (but my phone still shows crazy lines and while it doesn show much its enough to see that 1 option is white, 1 is green and the 2 others are red, I want the second red option, see the video...) -when you have navigated to the recovery (4th option) press power to select and hold the vol down button right after (so the phone wont override recovery flashed??)

at this point I see the phone drive pop up on my computer and I can also use adb on the phone. Of course it is wiped because I had to unlock the bootloader earlier.

Now Im thinking there is maybe 1 crazy way to get my files back. The Google Android backups! My new phone now is a LG and so I cant get the normal android backups on it but I want to try the 2 next things: use adb to screecast my broken phone on the computer and restore android backup?? use an emulator, put in my Google account and restore android backup. Maybe this can allow me to restore my lost files. It is weird that I can see my android backup in my google drive but there is no option to download it :(

=========EDIT 2

In the end my last idea did not work either. I was able to get a nexus 5 running in the genymotion emulator and add my google account to it. From there I could enable the backups but I could not find a way to restore a backup from my old phone anyways it seems that these android backups only contain app backups and settings backups. Im not sure it would contain the books I was accumulating in the Books folder or save games from Exiled Kingdoms. I guess I'm now giving up at this point.

It seems to me that if you lose your screen on your phone and -USB debugging is off -you have a PIN and home encrypted with the PIN -your bootloader is locked

There is no way you can recuperate your stuff from the device. Correct me if I'm wrong. Maybe I could have tried to talk to the phone "hello Google" and do something but I dont think I could because 1: it wasnt setup and 2: the cracked screen made the phone go crazy when booting normally.

Time to move on!

  • Correct, unlocking the bootloader wipes the /data partition. – Death Mask Salesman Aug 21 '17 at 19:28
  • 1
    Could you please post the question as a question and its answer as an answer below? Your effort to help fellow users is appreciated but please understand that this site conforms only to Q&A style, which means no forum like posts. – Firelord Aug 21 '17 at 20:08
  • Apart from what @Firelord said, you might also want to put the commands and their outputs in formatted text and/or blockquotes to increase readability. – Andy Yan Aug 22 '17 at 1:56
  • Fell awkwardly from the elliptic??? – iBug Aug 23 '17 at 11:54
  • @Firelord well Im hoping to retrieve my files. At this point my phone appears to be wiped but Im thinking maybe my files can be found in the Google android backups, basically I dont really have my answer yet... still working on this... – Pierre-Verthume Larivière Aug 24 '17 at 18:45
0

When unlocking bootloader device gets reset. All the data is lost. So it was a bad idea from start. You could have moved files using adb if possible.

  • This is not helpful. OP did not know at first hand what unlocking bootloader would do, but I'm surprised that the bootloader did not issue a warning on the console during unlock. – Firelord Aug 21 '17 at 20:06
  • It is just a warning. He has posted this as a Q&A. – Ashish Kafle Aug 22 '17 at 4:32
  • @AshishKafle unfortunately usb debugging was off on the phone so I could not connect via adb. I had to unlock the bootloader to be able to flash the twrp recover to be able to adb in. So I think it was impossible to recuperate the files, Im now hoping to somehow retrieve them from the android backups on Google. – Pierre-Verthume Larivière Aug 24 '17 at 18:47
0

It is possible that your don't have a broken screen but simply a loose connector inside the phone.

You can try to repair it yourself by opening the phone as described in this video:

https://www.youtube.com/watch?v=4pks4idq4YI

Probably you don't need a replacement part. Just disconnect and reconnect the connectors of the flat cable. It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.