3

I installed Android x86 on Hyper-V. I understand there are many difficulties to do this, like the display issue.

But I have to use Hyper-V since my main test environment is hosted on Hyper-V. I need the Android emulator also run on Hyper-V.

I got only one thing not completely solved - The mouse pointer.

The mouse pointer in Android is just not following my real mouse pointer, it is useless in Hyper-V. I noticed it is related to a module, called hid_hyperv. It's considered the HID driver for Hyper-V.

In Hyper-V console mode, I rmmod the hid_hyperv module, and it works fine when I use console directly.

However, if I RDP to the Hyper-V host and use the Hyper-V console, the mouse will not be captured without the "hid" module. Error message:

Mouse not captured in remote desktop session.

I think the cause is still related to the "hid" module, as once I insmod hid-hyperv, the error message won't show again, just that the mouse in Android still not follow my real mouse pointer.

I am frustrated to keep digging, any one has any suggestions or workarounds for this? I don't want to compile a hid_hyperv module for this to resolve it. But if there is some one already did this, I am glad to know. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.