0

I have a Xiaomi Redmi 1S running stock MIUI 7 global stable ROM and one day while I was using my phone it suddenly restarted and then it went into a bootloop. The phone would power on upon inserting the battery without pressing the Power button.
It kept restarting but by pressing down the Volume up button I could enter into the recovery mode. But the phone was still restarting after the a few seconds even in the recovery. But I could navigate within the recovery and I tried wiping the cache and then the phone restarted and later worked fine.
A week later, the phone suddenly restarted again and this time I am unable to navigate in the recovery. The phone just keeps restarting itself after a few seconds even in recovery and fastboot mode.
What could be the problem with my phone?

  • How restart occurs? while opening any application or simply from current page? – Rahul Gopi Aug 24 '17 at 6:48
  • @RahulGopi It just restarted when I opened a folder in the launcher and went into a bootloop. – M.Tarun Aug 24 '17 at 6:52
  • using default MIUI launcher right? – Rahul Gopi Aug 24 '17 at 6:53
  • @RahulGopi Yes, the default launcher. – M.Tarun Aug 24 '17 at 6:54
  • is it a default folder by MI, or created by you, or which apps are included in that folder. Is device reboots every time, while you open that folder. – Rahul Gopi Aug 24 '17 at 6:58
0

The issue was the phone hardly stayed in FASTBOOT MODE or Recovery Mode for 2-3 seconds and went back to boot loop. Basically it had to be really fast fingers when the phone is connected to LAPTOP to achieve this.

I did as mentioned in the post of @Robert_xes...

  1. On your laptop(I used a Windows 10) Download the fastboot.zip and unzip it and keep it ready. Download the latest MIUI Stable ROM and keep it in your desktop or if you have a SD Card remove it from your phone and copy it to SD cards and insert it back .

  2. The moment the phone is connected to laptop (it will start its bootloop) .. get it into fastboot mode (power and volume down) and the moment you get the fastboot logo, CLICK on flash_recovery.bat

    TWEAK -PLEASE NOTE GETTING INTO FASTBOOT MODE AND THE PHONE STATYING IN FASTBOOT LOGO SCREEN (WITHOUT GOING BACK INTO BOOT LOOP BEFORE YOU HIT FLASH_RECOVERY_BAT) MIGHT NOT HAPPEN THE FIRST TIME... IT TOOK ME AT LEAST 10-15 TIMES TO GET THE TIMING RIGHT WITH FAST FINGERS TO MAKE SURE FLASH_RECOVERY.BAT FILE PUSHES THE TWO FILES. You have to do this very very quickly. Keep trying again and again and again and again till his happens.(you will see for a fraction of second some file being pushed and an OKAY message at command prompt screen . If the PHONE is in BOOT LOOP then flash_recovery_bat will only show "waiting for Device/Signal" message. You need to keep doing this till it is achieved . Only then you can proceed to next step.

  3. Once step 2 is done. by now your phone would have gone back to its boot loop logo mode and you will be only seeing MI logo looping continuously. Now get into RECOVERY MODE by using the volume UP and Power button simultaneously. TWEAK - PLEASE NOTE. Again as indicated in step 2, since your phone is in BOOT LOOP you need to try this again and again till it gets into recovery mode... sometimes it will get into recovery mode but doesnt stay there and goes back to bootloop. As soon as it comes into recovery mode , hit the down arrow(which you will see in recovery mode) and NOW the phone stays in recovery mode.

  4. Once you have reached this step - 90% of your problem is solved as you have come into recovery mode and all you have to do now is follow the steps 7-9 of his solution. In my case I did not install new ROM , I just did a factory reset, wipe cache and wipe Dalvik Cache. The reason I didnt install new ROM was because the problem had started only after upgrade to MIUI 8.

  5. As Next Step - TWEAK - I used one of the options of recovery to do a POWER OFF. Then kept it for charging and waited patiently till charging. Most of the phones in boot loop would have had their battery drained

Credits:http://en.miui.com/forum.php?mod=viewthread&tid=663881&page=1#pid13355815

0

I tried to flash the device with recovery, fastboot but nothing worked.
The problem was a faulty power button. I disassembled the phone and checked the power button using a multi meter. It was faulty.
After removing the power button the phone is working again now. I use the charger to power on the phone either by using TWRP recovery or fastboot commands.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.