0

I'm not sure what's changed but the past week or two I've been getting notification ads for Google assistant every day, very annoying.

They take the format of 'why not call a friend?' 'Want a joke? ' - Turn assistant on! That kind of utterly valueless nonsense.

I believe these come from the Google app, but here's the thing:

1) Google App notifications are OFF 2) I cannot remove or disable the Google App

How do I stop these daily ads I didn't consent to? I've hunted and there is nothing in the settings anywhere allowing this.

Very grateful for help.

  • Thanks but the feed is already turned off, along with all notifications – Nathan Hornby Aug 24 '17 at 10:05
  • It may not be from assistant at all - please install app mentioned here and track from which app those things are emanating – beeshyams Aug 24 '17 at 10:34
  • Turns out turning off auto update on the play store has fixed it. No idea why or how, very unexpected - but it's done it! – Nathan Hornby Aug 26 '17 at 17:17
  • 1
    Great. Please self answer (and after couple of days accept it). It will help others with same problem – beeshyams Aug 26 '17 at 17:36
0

Turns out turning off auto update on the play store has fixed it. No idea why or how, very unexpected - but it's done it!

I'd be interested to hear if anyone else with this issue can resolve it the same way.

0

Note : The question isn't super specific on that in contrary to its title, so I'll assume that you have Assistant turned off or don't want it. I don't think there would be ads otherwise

OP stated that turning off auto update on the play store fixed his issue, which seems very random and probably unrelated to me. There's a sure way to disable these notifications though, and it's starting to be a known trick for people who don't want Google Assistant at all :


.

By changing your device's language to a less known regional variant of it, you'll make Google think that Assistant isn't available for you and your country, thus preventing it to be offered to you anymore by those "ads" or by long home button press.

For example, if you live in the U.S, and speak English, your device's primary language probably is "English (United States)". Changing it to "English (U.S Virgin Islands)" will make any mentions of Google Assistant disappear from your phone. In my case, my device's language is French (France), so I changed it to French (Swiss) to get rid of Assistant.

Keep in mind : Assistant may someday be available to all English countries so this solution isn't completely future-proof.

.

Self-Note : I made screenshots for a How-To part but I couldn't post them due to my low rep on this stackexchange. I'll probably update the answer when I'll be able to post these.

  • Thanks for the extra info, hopefully it's helpful to someone! I agree about the randomness of my solution, but it was actually after following advice is read elsewhere. Must be an odd connection between the play store and the Google standard apps; maybe even a bug – Nathan Hornby Oct 3 '17 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.