1

Recently all my virtual keyboards disappeared. Whenever I go to any app that needs keyboard input, the only option I get is voice input. If I tap the "X" to close the voice input, nothing happens. If I go to language & keyboard, then virtual keyboard, all it has is Google voice typing.

The only thing "suspicious" is that I recently went through a system update. I don't know if that specifically caused my issue but before the update it seems like I had my keyboard. I just didn't pay enough attention around the update to pinpoint it as the problem.

I've gotten around this issue by installing Gboard but I don't want a secondary app just to have a keyboard on my phone. I've searched through all my apps for anything with keyboard in the name and nothing is showing up.

Is there a way to reinstall the "default virtual keyboard"?

  • Can you go to play store and simply install Gboard again? – Једноруки Крстивоје Aug 24 '17 at 15:43
  • I did and have a keyboard back but would assume I don't need a 3rd party app to have a keyboard natively on my phone. – Craig O Aug 26 '17 at 18:36
0

Have you wiped cache/factory reset after update? Maybe check under language and input in settings to find the device's factory installed virtual keyboard.

Response: I don't want to do a factory reset. I've added a lot of apps and customized the "look and feel" and don't want to do that all over again. The keyboard was working after all that. I'm hoping for a different solution.

  • What phone are you using? Most manufacturers have a PC suite or software to backup user installed apps so that you can go back to custom settings after a reset. If performing a zero power reboot or cache wipe doesn't work, the only option left is factory reset. However before resetting I would recommend you freeze/disable apps to see if there could be any conflict. – SlickToes192 Aug 24 '17 at 15:45
  • I have an HTC Bolt. Only had it a couple of weeks. I'll look for what they use for backing up Apps. – Craig O Aug 25 '17 at 0:56
  • Hey since you use HTC try clearing cache/data of HTC Sense Input. Hope this helps – SlickToes192 Aug 25 '17 at 6:19
0

I recently had the same problem. I solved it by uninstalling GBoard updates and updating again GBoard.

  • Thanks Miki! Not sure why your answer has a -2 it worked for me. I recently disabled Google Boards (thinking it was a flip board type app) didn't realize it was the virtual keyboard. Enabled it and my virtual keyboard is back. Appreciate the comment. – Tom Mar 15 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.